summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorNeil Schemenauer <nascheme@enme.ucalgary.ca>2001-02-19 04:47:42 (GMT)
committerNeil Schemenauer <nascheme@enme.ucalgary.ca>2001-02-19 04:47:42 (GMT)
commit66252167620b8479e434257682b40cf30d21dce8 (patch)
tree607e0dd191c8ad07a5fd1fe640d167e9de413182 /configure.in
parentc5cfcb4a483456de67394e9e9ec94b9252587750 (diff)
downloadcpython-66252167620b8479e434257682b40cf30d21dce8.zip
cpython-66252167620b8479e434257682b40cf30d21dce8.tar.gz
cpython-66252167620b8479e434257682b40cf30d21dce8.tar.bz2
Use -G option for linking shared libraries on Solaris (SF patch #103656).
Compile shared object files using -fPIC option when using GCC on Solaris (SF patch #103865). Closes bug #132783. Move config.c generated by makesetup to the Modules directory.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index c9756f1..909b914 100644
--- a/configure.in
+++ b/configure.in
@@ -544,7 +544,7 @@ then
SunOS/4*) LDSHARED="ld";;
SunOS/5*)
if test "$GCC" = "yes"
- then LDSHARED='$(CC) -shared'
+ then LDSHARED='$(CC) -G'
else LDSHARED="ld -G";
fi ;;
hp*|HP*) LDSHARED="ld -b";;
@@ -590,6 +590,9 @@ AC_MSG_CHECKING(CCSHARED)
if test -z "$CCSHARED"
then
case $ac_sys_system/$ac_sys_release in
+ SunOS*) if test "$GCC" = yes;
+ then CCSHARED="-fPIC";
+ fi;;
hp*|HP*) if test "$GCC" = yes;
then CCSHARED="-fpic";
else CCSHARED="+z";
@@ -1441,3 +1444,4 @@ echo "creating Makefile"
$SHELL $srcdir/Modules/makesetup -c $srcdir/Modules/config.c.in \
-s Modules Modules/Setup.config \
Modules/Setup Modules/Setup.local
+mv config.c Modules