summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorFred Drake <fdrake@acm.org>1999-12-09 22:03:25 (GMT)
committerFred Drake <fdrake@acm.org>1999-12-09 22:03:25 (GMT)
commit89143df520f83ccf3083d507e92d64ab24d647d3 (patch)
tree7eaed70546cdd73023fd2c884040005bd5fe8454 /configure.in
parent5ab8eaf0bb97055aa41f96cd577f3e8e67c9c8bc (diff)
downloadcpython-89143df520f83ccf3083d507e92d64ab24d647d3.zip
cpython-89143df520f83ccf3083d507e92d64ab24d647d3.tar.gz
cpython-89143df520f83ccf3083d507e92d64ab24d647d3.tar.bz2
Added support for ctermid, tempnam, tmpfile, tmpnam, and tmpnam_r.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 3d3383c..8ba972a 100644
--- a/configure.in
+++ b/configure.in
@@ -679,13 +679,14 @@ DLINCLDIR=${dldir}
LIBS="$LIBS -ldl -ldld"], AC_MSG_RESULT(no))
# checks for library functions
-AC_CHECK_FUNCS(alarm chown clock dlopen execv flock fork \
+AC_CHECK_FUNCS(alarm chown clock ctermid ctermid_r dlopen execv flock fork \
fsync fdatasync ftime ftruncate \
getpeername getpgrp getpid getpwent gettimeofday getwd \
kill link lstat mkfifo mktime nice pause plock pthread_init putenv readlink \
select setgid setlocale setuid setsid setpgid setpgrp setvbuf \
sigaction siginterrupt sigrelse strftime strptime symlink \
- tcgetpgrp tcsetpgrp timegm times truncate uname waitpid)
+ tcgetpgrp tcsetpgrp tempnam timegm times tmpfile tmpnam tmpnam_r \
+ truncate uname waitpid)
# check for long file support functions
AC_CHECK_FUNCS(fseek64 fseeko fstatvfs ftell64 ftello statvfs)