summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>1997-01-21 22:02:36 (GMT)
committerGuido van Rossum <guido@python.org>1997-01-21 22:02:36 (GMT)
commitf78abae10f66918fe3dab24996ab7ded8df81843 (patch)
tree8113de7649ff67a911d5495a39ed273e59bc7ab3 /configure.in
parenta4240132ec0d59b5798453b4b09aff1a2840c240 (diff)
downloadcpython-f78abae10f66918fe3dab24996ab7ded8df81843.zip
cpython-f78abae10f66918fe3dab24996ab7ded8df81843.tar.gz
cpython-f78abae10f66918fe3dab24996ab7ded8df81843.tar.bz2
Let --with-threads be an alias for --with-thread.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5d60834..34113ca 100644
--- a/configure.in
+++ b/configure.in
@@ -306,6 +306,12 @@ then
fi
AC_MSG_CHECKING(for --with-thread)
+# Let --with-threads be an alias for --with-thread
+if test "${with_thread+set}" != set; then
+ if test "${with_threads+set}" = set; then
+ with_thread="$with_threads";
+ fi
+fi
AC_ARG_WITH(thread, [--with-thread[=DIRECTORY] make interpreter thread-safe], [
AC_MSG_RESULT($withval)
if test -d "$withval"