summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>1998-07-07 21:05:09 (GMT)
committerGuido van Rossum <guido@python.org>1998-07-07 21:05:09 (GMT)
commitf867812288840343db7f6de5c034b4bca42b8731 (patch)
tree73ef1ac1f762c70df0508b744297fb0719340021 /configure.in
parent82a5c66a51f8a655ea134ad0b02d0843c77e7f36 (diff)
downloadcpython-f867812288840343db7f6de5c034b4bca42b8731.zip
cpython-f867812288840343db7f6de5c034b4bca42b8731.tar.gz
cpython-f867812288840343db7f6de5c034b4bca42b8731.tar.bz2
Fix two unrelated problems in the same area:
(1) reorder the tests for -Olimit 1500 and -OPT:Olimit=0 so that the latter test is performed first, and if it works, the former test is skipped. This should get rid of the problem that the new SGI compilers accept both but emit a warning about -Olimit 1500. (2) The DGUX hack was somehow split in two by the Olimit tests, probably as the result of a non-context diff. Moved this back together again, after the Olimit tests.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in33
1 files changed, 17 insertions, 16 deletions
diff --git a/configure.in b/configure.in
index 14f3517..9cc643b 100644
--- a/configure.in
+++ b/configure.in
@@ -183,22 +183,6 @@ fi
AC_AIX
AC_MINIX
-if test "$MACHDEP" != "dguxR4"
-then
-AC_MSG_CHECKING(whether $CC accepts -Olimit 1500)
-AC_CACHE_VAL(ac_cv_olimit_ok,
-[ac_save_cc="$CC"
-CC="$CC -Olimit 1500"
-AC_TRY_RUN([int main() { return 0; }],
- ac_cv_olimit_ok=yes,
- ac_cv_olimit_ok=no)
-CC="$ac_save_cc"])
-AC_MSG_RESULT($ac_cv_olimit_ok)
-if test $ac_cv_olimit_ok = yes; then
- OPT="$OPT -Olimit 1500"
-fi
-
-AC_SUBST(DGUX_IS_BROKEN)
AC_MSG_CHECKING(whether $CC accepts -OPT:Olimit=0)
AC_CACHE_VAL(ac_cv_opt_olimit_ok,
[ac_save_cc="$CC"
@@ -210,7 +194,24 @@ CC="$ac_save_cc"])
AC_MSG_RESULT($ac_cv_opt_olimit_ok)
if test $ac_cv_opt_olimit_ok = yes; then
OPT="$OPT -OPT:Olimit=0"
+else
+ AC_MSG_CHECKING(whether $CC accepts -Olimit 1500)
+ AC_CACHE_VAL(ac_cv_olimit_ok,
+ [ac_save_cc="$CC"
+ CC="$CC -Olimit 1500"
+ AC_TRY_RUN([int main() { return 0; }],
+ ac_cv_olimit_ok=yes,
+ ac_cv_olimit_ok=no)
+ CC="$ac_save_cc"])
+ AC_MSG_RESULT($ac_cv_olimit_ok)
+ if test $ac_cv_olimit_ok = yes; then
+ OPT="$OPT -Olimit 1500"
+ fi
fi
+
+AC_SUBST(DGUX_IS_BROKEN)
+if test "$MACHDEP" != "dguxR4"
+then
REALLIBRARY='libpython$(VERSION).a'
DGUX_IS_BROKEN="true"
else