summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2005-08-07 21:09:30 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2005-08-07 21:09:30 (GMT)
commit147fbe5a558094f5690636476ca8da648703141a (patch)
treed7a9e39298f08b8b0c3aea3fb38af3ca7d9c3fb7 /configure.in
parentb813c53cd892a8de90b0ed172e8964b3e61124df (diff)
downloadcpython-147fbe5a558094f5690636476ca8da648703141a.zip
cpython-147fbe5a558094f5690636476ca8da648703141a.tar.gz
cpython-147fbe5a558094f5690636476ca8da648703141a.tar.bz2
Patch #1239112: Correct LINKCC C++ test. Fixes #1189330.
Backported to 2.4.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 101fd44..7d6fe82 100644
--- a/configure.in
+++ b/configure.in
@@ -471,9 +471,11 @@ then
if test -z "$CXX"; then
LINKCC="\$(PURIFY) \$(CC)"
else
- echo 'void foo();int main(){foo();}void foo(){}' > conftest.$ac_ext
- $CXX -c conftest.$ac_ext 2>&5
- if $CC -o conftest$ac_exeext conftest.$ac_objext 2>&5 \
+ echo 'extern "C" void foo();int main(){foo();}' > conftest_a.cc
+ $CXX -c conftest_a.cc # 2>&5
+ echo 'void foo(){}' > conftest_b.$ac_ext
+ $CC -c conftest_b.$ac_ext # 2>&5
+ if $CC -o conftest$ac_exeext conftest_a.$ac_objext conftest_b.$ac_objext 2>&5 \
&& test -s conftest$ac_exeext && ./conftest$ac_exeext
then
LINKCC="\$(PURIFY) \$(CC)"