summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2010-10-31 16:50:44 (GMT)
committerBenjamin Peterson <benjamin@python.org>2010-10-31 16:50:44 (GMT)
commit79263252b1094887c9776b97c1f76956fb0e51b8 (patch)
tree58ecd4ec757c1257c81eb792be3e8aec3d8983ec /configure.in
parentc73206c1e1c6cc7b177ad23ac53dc73db66c13a9 (diff)
downloadcpython-79263252b1094887c9776b97c1f76956fb0e51b8.zip
cpython-79263252b1094887c9776b97c1f76956fb0e51b8.tar.gz
cpython-79263252b1094887c9776b97c1f76956fb0e51b8.tar.bz2
add no output to with-system-ffi and with-system-expat
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 2610657..24bbdda 100644
--- a/configure.in
+++ b/configure.in
@@ -1934,14 +1934,18 @@ AC_PATH_TOOL([PKG_CONFIG], [pkg-config])
# Check for use of the system expat library
AC_MSG_CHECKING(for --with-system-expat)
AC_ARG_WITH(system_expat,
- AS_HELP_STRING([--with-system-expat], [build pyexpat module using an installed expat library]))
+ AS_HELP_STRING([--with-system-expat], [build pyexpat module using an installed expat library]),
+ [],
+ [with_system_expat="no"])
AC_MSG_RESULT($with_system_expat)
# Check for use of the system libffi library
AC_MSG_CHECKING(for --with-system-ffi)
AC_ARG_WITH(system_ffi,
- AS_HELP_STRING([--with-system-ffi], [build _ctypes module using an installed ffi library]))
+ AS_HELP_STRING([--with-system-ffi], [build _ctypes module using an installed ffi library]),
+ [],
+ [with_system_ffi="no"])
if test "$with_system_ffi" = "yes" && test -n "$PKG_CONFIG"; then
LIBFFI_INCLUDEDIR="`"$PKG_CONFIG" libffi --cflags-only-I 2>/dev/null | sed -e 's/^-I//;s/ *$//'`"