summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2009-12-13 02:10:36 (GMT)
committerBenjamin Peterson <benjamin@python.org>2009-12-13 02:10:36 (GMT)
commit8f326b23695dc4996327da8477e11aad42c61953 (patch)
tree4e958dc9812fe6417eb75ea30a1bd409e2341c73 /configure.in
parent0496c9ee0a6937eaa94800a74749086add28e27f (diff)
downloadcpython-8f326b23695dc4996327da8477e11aad42c61953.zip
cpython-8f326b23695dc4996327da8477e11aad42c61953.tar.gz
cpython-8f326b23695dc4996327da8477e11aad42c61953.tar.bz2
Merged revisions 76052,76522,76591,76689,76697,76733 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r76052 | gregory.p.smith | 2009-11-01 20:02:38 -0600 (Sun, 01 Nov 2009) | 5 lines see issue1006238, this merges in the following patch to ease cross compiling the printf %zd check. http://sources.gentoo.org/viewcvs.py/gentoo-x86/dev-lang/python/files/python-2.5-cross-printf.patch?rev=1.1&view=markup ........ r76522 | barry.warsaw | 2009-11-25 12:38:32 -0600 (Wed, 25 Nov 2009) | 2 lines Add mktime_tz to __all__. It's documented as being available in email.utils. ........ r76591 | benjamin.peterson | 2009-11-29 16:26:26 -0600 (Sun, 29 Nov 2009) | 4 lines now that deepcopy can handle instance methods, this hack can be removed #7409 Thanks Robert Collins ........ r76689 | benjamin.peterson | 2009-12-06 11:37:48 -0600 (Sun, 06 Dec 2009) | 1 line rewrite translate_newlines for clarity ........ r76697 | benjamin.peterson | 2009-12-06 15:24:30 -0600 (Sun, 06 Dec 2009) | 2 lines fix test_parser from tokenizer tweak ........ r76733 | benjamin.peterson | 2009-12-09 21:37:59 -0600 (Wed, 09 Dec 2009) | 1 line substitute PyDict_Check() for PyObject_IsInstance ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 6 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 45601d5..711856d 100644
--- a/configure.in
+++ b/configure.in
@@ -3905,9 +3905,8 @@ then
LIBS="$LIBS -framework CoreFoundation"
fi
-AC_MSG_CHECKING(for %zd printf() format support)
-AC_CACHE_VAL(ac_cv_have_size_t_format,
-AC_TRY_RUN([[
+AC_CACHE_CHECK([for %zd printf() format support], ac_cv_have_size_t_format, [dnl
+AC_TRY_RUN([
#include <stdio.h>
#include <stddef.h>
#include <string.h>
@@ -3942,13 +3941,11 @@ int main()
return 0;
}
-]], ac_cv_have_size_t_format=yes,
+], ac_cv_have_size_t_format=yes,
ac_cv_have_size_t_format=no,
- ac_cv_have_size_t_format=no)
-)
-AC_MSG_RESULT($ac_cv_have_size_t_format)
-if test $ac_cv_have_size_t_format = yes
-then
+ [ac_cv_have_size_t_format="cross -- assuming yes"]
+)])
+if test "$ac_cv_have_size_t_format" != no ; then
AC_DEFINE(PY_FORMAT_SIZE_T, "z",
[Define to printf format modifier for Py_ssize_t])
fi