summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTravis E. Oliphant <oliphant@enthought.com>2007-10-12 22:06:37 (GMT)
committerTravis E. Oliphant <oliphant@enthought.com>2007-10-12 22:06:37 (GMT)
commit9b30784ab2867bcb7335add7306bbd71e2de2151 (patch)
tree840e42d2f374c9e6e0be3aa8371f675624930c65 /configure.in
parentd5c0add332c9eedc74d57232c6c459b297d63cf5 (diff)
downloadcpython-9b30784ab2867bcb7335add7306bbd71e2de2151.zip
cpython-9b30784ab2867bcb7335add7306bbd71e2de2151.tar.gz
cpython-9b30784ab2867bcb7335add7306bbd71e2de2151.tar.bz2
Add macros for checking for long double and defining the size of long double on the platform. Ctypes and Struct module will both need them.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 4d09bed..696e724 100644
--- a/configure.in
+++ b/configure.in
@@ -1197,6 +1197,18 @@ if test "$have_long_long" = yes ; then
AC_CHECK_SIZEOF(long long, 8)
fi
+AC_MSG_CHECKING(for long double support)
+have_long_double=no
+AC_TRY_COMPILE([], [long double x; x = (long double)0;], [
+ AC_DEFINE(HAVE_LONG_DOUBLE, 1, [Define this if you have the type long double.])
+ have_long_double=yes
+])
+AC_MSG_RESULT($have_long_double)
+if test "$have_long_double" = yes ; then
+AC_CHECK_SIZEOF(long double, 16)
+fi
+
+
AC_MSG_CHECKING(for _Bool support)
have_c99_bool=no
AC_TRY_COMPILE([], [_Bool x; x = (_Bool)0;], [