summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2009-09-29 13:00:44 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2009-09-29 13:00:44 (GMT)
commit9ebd242fbbd2c52fcf314e22f6b5bf57954d52cd (patch)
tree47f64f77073c5de5ec4c894a19c3b329c950c65d /configure.in
parentf70867aabcd3a524cb03d7126ca1aaddfbb981d4 (diff)
downloadcpython-9ebd242fbbd2c52fcf314e22f6b5bf57954d52cd.zip
cpython-9ebd242fbbd2c52fcf314e22f6b5bf57954d52cd.tar.gz
cpython-9ebd242fbbd2c52fcf314e22f6b5bf57954d52cd.tar.bz2
* Update the Mac/README file. Add the list of OSX-specific configure options
to that README file with some explanation. * Be more strict in the configure script: complain loudly when the user has specified invalid combinations of OSX-specific configure arguments. The error message refers to the Mac/README file for more information.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 4c4731f..4713d57 100644
--- a/configure.in
+++ b/configure.in
@@ -118,6 +118,11 @@ AC_ARG_WITH(universal-archs,
[
AC_MSG_RESULT($withval)
UNIVERSAL_ARCHS="$withval"
+ if test "${enable_universalsdk}" ; then
+ :
+ else
+ AC_MSG_ERROR([--with-universal-archs without --enable-universalsdk. See Mac/README])
+ fi
],
[
AC_MSG_RESULT(32-bit)
@@ -129,6 +134,11 @@ AC_ARG_WITH(framework-name,
AC_HELP_STRING(--with-framework-name=FRAMEWORK,
specify an alternate name of the framework built with --enable-framework),
[
+ if test "${enable_framework}"; then
+ :
+ else
+ AC_MSG_ERROR([--with-framework-name without --enable-framework. See Mac/README])
+ fi
PYTHONFRAMEWORK=${withval}
PYTHONFRAMEWORKDIR=${withval}.framework
PYTHONFRAMEWORKIDENTIFIER=org.python.`echo $withval | tr '[A-Z]' '[a-z]'`
@@ -1615,7 +1625,7 @@ then
AC_MSG_RESULT(yes)
if test $enable_shared = "yes"
then
- AC_MSG_ERROR([Specifying both --enable-shared and --enable-framework is not supported, use only --enable-framework instead])
+ AC_MSG_ERROR([Specifying both --enable-shared and --enable-framework is not supported, use only --enable-framework instead. See Mac/README.])
fi
else
AC_MSG_RESULT(no)