summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2007-12-04 08:37:59 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2007-12-04 08:37:59 (GMT)
commita51d5c8c15c3317843848737f20ec739e31427f9 (patch)
tree8a019ef5c5550f8d12bd64ceb06e484f9fabed4d /configure.in
parent7b3cc06a9a26e38f379ac802e857a463970e35fa (diff)
downloadcpython-a51d5c8c15c3317843848737f20ec739e31427f9.zip
cpython-a51d5c8c15c3317843848737f20ec739e31427f9.tar.gz
cpython-a51d5c8c15c3317843848737f20ec739e31427f9.tar.bz2
Fix chflags issue on Tru64, from #1490190.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in36
1 files changed, 34 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 4c6dee9..b0313e2 100644
--- a/configure.in
+++ b/configure.in
@@ -2303,11 +2303,11 @@ fi
AC_MSG_RESULT(MACHDEP_OBJS)
# checks for library functions
-AC_CHECK_FUNCS(alarm bind_textdomain_codeset chflags chown clock confstr \
+AC_CHECK_FUNCS(alarm bind_textdomain_codeset chown clock confstr \
ctermid execv fchmod fchown fork fpathconf ftime ftruncate \
gai_strerror getgroups getlogin getloadavg getpeername getpgid getpid \
getpriority getpwent getspnam getspent getsid getwd \
- kill killpg lchflags lchmod lchown lstat mkfifo mknod mktime \
+ kill killpg lchmod lchown lstat mkfifo mknod mktime \
mremap nice pathconf pause plock poll pthread_init \
putenv readlink realpath \
select setegid seteuid setgid \
@@ -2400,6 +2400,38 @@ AC_CHECK_LIB(c, inet_aton, [$ac_cv_prog_TRUE],
AC_CHECK_LIB(resolv, inet_aton)
)
+# On Tru64, chflags seems to be present, but calling it will
+# exit Python
+AC_MSG_CHECKING(for chflags)
+AC_TRY_RUN([
+#include <sys/stat.h>
+#include <unistd.h>
+int main(int argc, char*argv[])
+{
+ if(chflags(argv[0], 0) != 0)
+ return 1;
+ return 0;
+}
+],AC_DEFINE(HAVE_CHFLAGS, 1, Define to 1 if you have the `chflags' function.)
+ AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no)
+)
+
+AC_MSG_CHECKING(for lchflags)
+AC_TRY_RUN([
+#include <sys/stat.h>
+#include <unistd.h>
+int main(int argc, char*argv[])
+{
+ if(lchflags(argv[0], 0) != 0)
+ return 1;
+ return 0;
+}
+],AC_DEFINE(HAVE_LCHFLAGS, 1, Define to 1 if you have the `lchflags' function.)
+ AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no)
+)
+
dnl Check if system zlib has *Copy() functions
dnl
dnl On MacOSX the linker will search for dylibs on the entire linker path