summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2001-01-17 08:25:11 (GMT)
committerEric S. Raymond <esr@thyrsus.com>2001-01-17 08:25:11 (GMT)
commita88854059309667092000da55d4d5a5804267e9f (patch)
tree90884007bfdb5147f969b5e52340c6bc573fb3c3 /configure.in
parent90badd1286eadad22761105d7211f1e02a1f6845 (diff)
downloadcpython-a88854059309667092000da55d4d5a5804267e9f.zip
cpython-a88854059309667092000da55d4d5a5804267e9f.tar.gz
cpython-a88854059309667092000da55d4d5a5804267e9f.tar.bz2
Eric the half-a-wit, driven to berserk rage after repeatedly doing
builds during which he forgot to uncomment crucial library lines in Setup, walks into Guido's East End nightclub with a tactical nuclear weapon on his shoulder. Said nuclear weapon is promptly deployed exactly where it will do the most good, right in the middle of configure.in. With this patch, the set of libraries autoconfigured in is extended to include ndbm, gdbm, and crypt. This essentially eliminates any need to tweak Setup for a normal Linux build. "'E was a fair man. Cruel, but fair."
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in35
1 files changed, 31 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 61dead1..55e93cd 100644
--- a/configure.in
+++ b/configure.in
@@ -749,19 +749,46 @@ AC_MSG_RESULT($withval)
LIBS="$withval $LIBS"
], AC_MSG_RESULT(no))
-# This is used to generate Setup.config
+#
+# These are used to generate Setup.config. They autoconfigure several
+# features that are otherwise severe pains in the butt.
+#
+# ncurses
AC_SUBST(USE_NCURSES_MODULE)
AC_CHECK_LIB(ncurses, initscr,
[USE_NCURSES_MODULE=""],
[USE_NCURSES_MODULE="#"],
-ltermcap)
-
-# This is used to generate Setup.config
+# GNU readline
AC_SUBST(USE_READLINE_MODULE)
AC_CHECK_LIB(readline, readline,
[USE_READLINE_MODULE=""],
[USE_READLINE_MODULE="#"],
-ltermcap)
+# gdbm(3)
+AC_SUBST(USE_GDBM_MODULE)
+AC_SUBST(HAVE_LIBGDBM)
+AC_CHECK_LIB(gdbm, gdbm_open,
+ [USE_GDBM_MODULE=""
+ HAVE_LIBGDBM=-lgdbm],
+ [USE_GDBM_MODULE="#"
+ HAVE_LIBGDBM=""])
+# ndbm(3)
+AC_SUBST(USE_NDBM_MODULE)
+AC_SUBST(HAVE_LIBNDBM)
+AC_CHECK_LIB(ndbm, ndbm_open,
+ [USE_NDBM_MODULE=""
+ HAVE_LIBNDBM=-lndbm],
+ [USE_NDBM_MODULE="#"
+ HAVE_LIBNDBM=""])
+# crypt(3)
+AC_SUBST(USE_CRYPT_MODULE)
+AC_SUBST(HAVE_LIBCRYPT)
+AC_CHECK_LIB(crypt, crypt,
+ [USE_CRYPT_MODULE=""
+ HAVE_LIBCRYPT=-lcrypt],
+ [USE_CRYPT_MODULE="#"
+ HAVE_LIBCRYPT=""])
# This is used to generate Setup.config
AC_SUBST(USE_THREAD_MODULE)
@@ -905,7 +932,7 @@ else
# make sure user knows why dbm support wasn't enabled even though
# s/he requested it
if test "$with_dbm" = "yes"
- then echo $ac_n "(requested by no ndbm.h was found) $ac_c"
+ then echo $ac_n "(requested but no ndbm.h was found) $ac_c"
fi
with_dbm="no"
fi