summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2011-03-06 09:13:00 (GMT)
committerGeorg Brandl <georg@python.org>2011-03-06 09:13:00 (GMT)
commit13039c87f14aeed325bcb5fadd202922a614957b (patch)
treef78ce4e5acffdb796e9c1803a7b2127100f5fd4f /configure.in
parent80d3610bc36e484fbe7b7ccce366a73314505a16 (diff)
parent8256242b30005b8a1b52e79149558ad36f1307d6 (diff)
downloadcpython-13039c87f14aeed325bcb5fadd202922a614957b.zip
cpython-13039c87f14aeed325bcb5fadd202922a614957b.tar.gz
cpython-13039c87f14aeed325bcb5fadd202922a614957b.tar.bz2
Merge build identification to 3.2 branch.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 6f4ffa5..aaeb9bc 100644
--- a/configure.in
+++ b/configure.in
@@ -817,6 +817,21 @@ else
SVNVERSION="echo Unversioned directory"
fi
+AC_SUBST(HGVERSION)
+AC_SUBST(HGTAG)
+AC_SUBST(HGBRANCH)
+AC_CHECK_PROG(HAS_HG, hg, found, not-found)
+if test $HAS_HG = found
+then
+ HGVERSION="hg id -i \$(srcdir)"
+ HGTAG="hg id -t \$(srcdir)"
+ HGBRANCH="hg id -b \$(srcdir)"
+else
+ HGVERSION=""
+ HGTAG=""
+ HGBRANCH=""
+fi
+
case $MACHDEP in
bsdos*|hp*|HP*)
# install -d does not work on BSDI or HP-UX