summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSkip Montanaro <skip@pobox.com>2006-04-13 02:00:56 (GMT)
committerSkip Montanaro <skip@pobox.com>2006-04-13 02:00:56 (GMT)
commit288a5be5adf6d9ea5ca7c74cf440128bc7029d04 (patch)
tree45811a0785451cab74929a756d66b07886047d78 /configure.in
parent57fdcbc60ff8bbb0261f5dba47580194d45c31a3 (diff)
downloadcpython-288a5be5adf6d9ea5ca7c74cf440128bc7029d04.zip
cpython-288a5be5adf6d9ea5ca7c74cf440128bc7029d04.tar.gz
cpython-288a5be5adf6d9ea5ca7c74cf440128bc7029d04.tar.bz2
If compiling with g++ don't use -Wstrict-prototpes.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 027dc50..db3b33a 100644
--- a/configure.in
+++ b/configure.in
@@ -685,18 +685,21 @@ if test -z "$OPT"
then
case $GCC in
yes)
+ if test "$CC" != 'g++' ; then
+ STRICT_PROTO="-Wstrict-prototypes"
+ fi
case $ac_cv_prog_cc_g in
yes)
if test "$Py_DEBUG" = 'true' ; then
# Optimization messes up debuggers, so turn it off for
# debug builds.
- OPT="-g -Wall -Wstrict-prototypes"
+ OPT="-g -Wall $STRICT_PROTO"
else
- OPT="-g -O3 -Wall -Wstrict-prototypes"
+ OPT="-g -O3 -Wall $STRICT_PROTO"
fi
;;
*)
- OPT="-O3 -Wall -Wstrict-prototypes"
+ OPT="-O3 -Wall $STRICT_PROTO"
;;
esac
case $ac_sys_system in