summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorChristian Heimes <christian@cheimes.de>2007-12-04 15:00:33 (GMT)
committerChristian Heimes <christian@cheimes.de>2007-12-04 15:00:33 (GMT)
commitd0764e2bd15d5900b73ec3d4b54fb2b45a3006f0 (patch)
treeaa42b5908aff75417b4d687973e352e6b74502ea /configure.in
parentde10c85314b1f351b4d75414c55175c00a921175 (diff)
downloadcpython-d0764e2bd15d5900b73ec3d4b54fb2b45a3006f0.zip
cpython-d0764e2bd15d5900b73ec3d4b54fb2b45a3006f0.tar.gz
cpython-d0764e2bd15d5900b73ec3d4b54fb2b45a3006f0.tar.bz2
Merged revisions 59313-59320 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r59317 | martin.v.loewis | 2007-12-04 09:37:59 +0100 (Tue, 04 Dec 2007) | 2 lines Fix chflags issue on Tru64, from #1490190. ........ r59318 | martin.v.loewis | 2007-12-04 09:39:16 +0100 (Tue, 04 Dec 2007) | 2 lines Move nt.access change into the right section. ........ r59320 | christian.heimes | 2007-12-04 15:57:30 +0100 (Tue, 04 Dec 2007) | 2 lines Added self generated UUID for msvcr90.dll to msi.py Readded a missing line. ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in36
1 files changed, 34 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 608d6ae..2e7ebae 100644
--- a/configure.in
+++ b/configure.in
@@ -2274,11 +2274,11 @@ fi
AC_MSG_RESULT(MACHDEP_OBJS)
# checks for library functions
-AC_CHECK_FUNCS(alarm bind_textdomain_codeset chflags chown clock confstr \
+AC_CHECK_FUNCS(alarm bind_textdomain_codeset chown clock confstr \
ctermid execv fchmod fchown fork fpathconf ftime ftruncate \
gai_strerror getgroups getlogin getloadavg getpeername getpgid getpid \
getpriority getpwent getspnam getspent getsid getwd \
- kill killpg lchflags lchmod lchown lstat mkfifo mknod mktime \
+ kill killpg lchmod lchown lstat mkfifo mknod mktime \
mremap nice pathconf pause plock poll pthread_init \
putenv readlink realpath \
select setegid seteuid setgid \
@@ -2371,6 +2371,38 @@ AC_CHECK_LIB(c, inet_aton, [$ac_cv_prog_TRUE],
AC_CHECK_LIB(resolv, inet_aton)
)
+# On Tru64, chflags seems to be present, but calling it will
+# exit Python
+AC_MSG_CHECKING(for chflags)
+AC_TRY_RUN([
+#include <sys/stat.h>
+#include <unistd.h>
+int main(int argc, char*argv[])
+{
+ if(chflags(argv[0], 0) != 0)
+ return 1;
+ return 0;
+}
+],AC_DEFINE(HAVE_CHFLAGS, 1, Define to 1 if you have the `chflags' function.)
+ AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no)
+)
+
+AC_MSG_CHECKING(for lchflags)
+AC_TRY_RUN([
+#include <sys/stat.h>
+#include <unistd.h>
+int main(int argc, char*argv[])
+{
+ if(lchflags(argv[0], 0) != 0)
+ return 1;
+ return 0;
+}
+],AC_DEFINE(HAVE_LCHFLAGS, 1, Define to 1 if you have the `lchflags' function.)
+ AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no)
+)
+
dnl Check if system zlib has *Copy() functions
dnl
dnl On MacOSX the linker will search for dylibs on the entire linker path