summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSkip Montanaro <skip@pobox.com>2000-09-08 02:17:15 (GMT)
committerSkip Montanaro <skip@pobox.com>2000-09-08 02:17:15 (GMT)
commited33c9af972feb1feb5a045f2f439145735dcbbe (patch)
tree07ca888dd1768f7c2977b1b5e933623eab2918a1 /configure.in
parent6c8affe59007f94c899bb3feb8f987f93f5fcf2f (diff)
downloadcpython-ed33c9af972feb1feb5a045f2f439145735dcbbe.zip
cpython-ed33c9af972feb1feb5a045f2f439145735dcbbe.tar.gz
cpython-ed33c9af972feb1feb5a045f2f439145735dcbbe.tar.bz2
autodetect presence of libdb - this allows bsddbmodule to be built
automatically if dbopen is found in libc or libdb. This closes patch #101420
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 86b816d..be8ee9b 100644
--- a/configure.in
+++ b/configure.in
@@ -836,6 +836,13 @@ else
fi
AC_MSG_RESULT($with_libdb)
+if test "$with_libdb" = "yes"
+then
+ # check for libdb; BSD systems have the DB routines in libc --tg
+ AC_SUBST(HAVE_LIBDB)
+ AC_CHECK_FUNC(dbopen, [HAVE_LIBDB=], AC_CHECK_LIB(db, dbopen, [HAVE_LIBDB=-ldb]))
+fi
+
# Check for --with-wctype-functions
AC_MSG_CHECKING(for --with-wctype-functions)
AC_ARG_WITH(wctype-functions,