summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2009-09-08 07:12:42 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2009-09-08 07:12:42 (GMT)
commit3c064c172a0f075ad94bfaafe8823a05bc9b7cb8 (patch)
tree9f3c281bdb005545ccfda16fa80f4139e4b49ef2 /configure.in
parent825fce34b1a060a43f9cb7244c1b0062e26af745 (diff)
downloadcpython-3c064c172a0f075ad94bfaafe8823a05bc9b7cb8.zip
cpython-3c064c172a0f075ad94bfaafe8823a05bc9b7cb8.tar.gz
cpython-3c064c172a0f075ad94bfaafe8823a05bc9b7cb8.tar.bz2
Merged revisions 74701 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r74701 | ronald.oussoren | 2009-09-07 08:12:00 +0200 (Mon, 07 Sep 2009) | 2 lines Fix typo in configure.in ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 22 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 01d7585..4f2d3e0 100644
--- a/configure.in
+++ b/configure.in
@@ -114,7 +114,7 @@ AC_SUBST(ARCH_RUN_32BIT)
UNIVERSAL_ARCHS="32-bit"
AC_MSG_CHECKING(for --with-universal-archs)
AC_ARG_WITH(universal-archs,
- AC_HELP_STRING(--with-universal-archs=ARCH, select architectures for universal build ("32-bit", "64-bit" or "all")),
+ AC_HELP_STRING(--with-universal-archs=ARCH, select architectures for universal build ("32-bit", "64-bit", "3-way", "intel" or "all")),
[
AC_MSG_RESULT($withval)
UNIVERSAL_ARCHS="$withval"
@@ -925,6 +925,14 @@ yes)
UNIVERSAL_ARCH_FLAGS="-arch i386 -arch ppc -arch ppc64 -arch x86_64"
ARCH_RUN_32BIT="arch -i386 -ppc"
+ elif test "$UNIVERSAL_ARCHS" = "intel" ; then
+ UNIVERSAL_ARCH_FLAGS="-arch i386 -arch x86_64"
+ ARCH_RUN_32BIT="arch -i386"
+
+ elif test "$UNIVERSAL_ARCHS" = "3-way" ; then
+ UNIVERSAL_ARCH_FLAGS="-arch i386 -arch ppc -arch x86_64"
+ ARCH_RUN_32BIT="arch -i386 -ppc"
+
else
AC_MSG_ERROR([proper usage is --with-universalarch=32-bit|64-bit|all])
@@ -950,6 +958,15 @@ yes)
# that's the first OS release where
# 4-way builds make sense.
cur_target='10.5'
+
+ elif test "${UNIVERSAL_ARCHS}" = "3-way"; then
+ cur_target='10.5'
+
+ elif test "${UNIVERSAL_ARCHS}" = "intel"; then
+ cur_target='10.5'
+
+ elif test "${UNIVERSAL_ARCHS}" = "64-bit"; then
+ cur_target='10.5'
fi
else
if test `arch` = "i386"; then
@@ -1486,7 +1503,7 @@ case $ac_sys_system/$ac_sys_release in
else
LIBTOOL_CRUFT=""
fi
- AC_TRY_RUN([[
+ AC_TRY_RUN([
#include <unistd.h>
int main(int argc, char*argv[])
{
@@ -1495,9 +1512,10 @@ case $ac_sys_system/$ac_sys_release in
} else {
return 1;
}
- ]], ac_osx_32bit=yes,
+ }
+ ], ac_osx_32bit=yes,
ac_osx_32bit=no,
- ac_osx_32bit=no)
+ ac_osx_32bit=yes)
if test "${ac_osx_32bit}" = "yes"; then
case `arch` in