summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2010-02-07 12:03:42 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2010-02-07 12:03:42 (GMT)
commit8af24c111bd5f4383d46ebbadd554b1d2686331f (patch)
treecaba718e10a6b847d9e9bad5d3ecbbf30e8847c5 /configure.in
parent9812a6cf24378d95eb7699da452eb74825e9a3cb (diff)
downloadcpython-8af24c111bd5f4383d46ebbadd554b1d2686331f.zip
cpython-8af24c111bd5f4383d46ebbadd554b1d2686331f.tar.gz
cpython-8af24c111bd5f4383d46ebbadd554b1d2686331f.tar.bz2
* Checks that the SDK specified with --enable-universalsk=VALUE exists.
* Fall back to the default system SDK when specifying --enable-universalsk without a value and the 10.4u SDK is not avaiable. Port of fix for issue 4834 from the trunk.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 4459ec3..58ceea6 100644
--- a/configure.in
+++ b/configure.in
@@ -86,12 +86,17 @@ define_xopen_source=yes
AC_SUBST(CONFIG_ARGS)
CONFIG_ARGS="$ac_configure_args"
+AC_MSG_CHECKING([for --enable-universalsdk])
AC_ARG_ENABLE(universalsdk,
AC_HELP_STRING(--enable-universalsdk@<:@=SDKDIR@:>@, Build against Mac OS X 10.4u SDK (ppc/i386)),
[
case $enableval in
yes)
enableval=/Developer/SDKs/MacOSX10.4u.sdk
+ if test ! -d "${enableval}"
+ then
+ enableval=/
+ fi
;;
esac
case $enableval in
@@ -101,12 +106,23 @@ AC_ARG_ENABLE(universalsdk,
;;
*)
UNIVERSALSDK=$enableval
+ if test ! -d "${UNIVERSALSDK}"
+ then
+ AC_MSG_ERROR([--enable-universalsdk specifies non-existing SDK: ${UNIVERSALSDK}])
+ fi
;;
esac
+
],[
UNIVERSALSDK=
enable_universalsdk=
])
+if test -n "${UNIVERSALSDK}"
+then
+ AC_MSG_RESULT(${UNIVERSALSDK})
+else
+ AC_MSG_RESULT(no)
+fi
AC_SUBST(UNIVERSALSDK)
AC_SUBST(ARCH_RUN_32BIT)