summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorNeil Schemenauer <nascheme@enme.ucalgary.ca>2001-01-27 21:39:17 (GMT)
committerNeil Schemenauer <nascheme@enme.ucalgary.ca>2001-01-27 21:39:17 (GMT)
commitd9cf41c4381bf7e7f09dfbb986dee52fff6c3114 (patch)
tree4a9ad9bcf8c6ab790a6d4fae6ea7398c3c203b07 /configure.in
parent2174f80c66a7f9e8d39ac09d5d367e78ca743eea (diff)
downloadcpython-d9cf41c4381bf7e7f09dfbb986dee52fff6c3114.zip
cpython-d9cf41c4381bf7e7f09dfbb986dee52fff6c3114.tar.gz
cpython-d9cf41c4381bf7e7f09dfbb986dee52fff6c3114.tar.bz2
- Remove Guido's LINKCC=CXX experiment.
- Cygwin doesn't want CCSHARED flag when bulding the interpreter DLL.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 554aa93..0fd8cee 100644
--- a/configure.in
+++ b/configure.in
@@ -221,10 +221,6 @@ DLLLIBRARY=''
# linking.
AC_SUBST(LINKCC)
AC_MSG_CHECKING(LINKCC)
-if test -z "$LINKCC" -a ! -z "$CXX"
-then
- LINKCC="$CXX"
-fi
if test -z "$LINKCC"
then
case $ac_sys_system in
@@ -647,7 +643,14 @@ AC_SUBST(CFLAGSFORSHARED)
AC_MSG_CHECKING(CFLAGSFORSHARED)
if test ! "$LIBRARY" = "$LDLIBRARY"
then
- CFLAGSFORSHARED='$(CCSHARED)'
+ case $ac_sys_system in
+ CYGWIN*)
+ # Cygwin needs CCSHARED when building extension DLLs
+ # but not when building the interpreter DLL.
+ CFLAGSFORSHARED='';;
+ *)
+ CFLAGSFORSHARED='$(CCSHARED)'
+ esac
fi
AC_MSG_RESULT($CFLAGSFORSHARED)