summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMark Dickinson <dickinsm@gmail.com>2009-01-05 17:10:09 (GMT)
committerMark Dickinson <dickinsm@gmail.com>2009-01-05 17:10:09 (GMT)
commit0f6325718a92f78c1ea319908f199bec2fa71ee1 (patch)
tree5bc127c51373b7c6e1b4103ef0ae555efc9b3555 /configure.in
parent52144f5782a136d92e67152d641564d233347648 (diff)
downloadcpython-0f6325718a92f78c1ea319908f199bec2fa71ee1.zip
cpython-0f6325718a92f78c1ea319908f199bec2fa71ee1.tar.gz
cpython-0f6325718a92f78c1ea319908f199bec2fa71ee1.tar.bz2
Merged revisions 68312 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r68312 | mark.dickinson | 2009-01-04 20:19:41 +0000 (Sun, 04 Jan 2009) | 4 lines It's wrong to use AC_REPLACE_FUNCS for hypot, since there's no longer any Python/hypot.c replacement file. Use AC_CHECK_FUNCS instead. This change should be backported to 2.6 and 3.0. ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 1 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index d80e7a7..17f7d11 100644
--- a/configure.in
+++ b/configure.in
@@ -3120,9 +3120,7 @@ then
[Define if tanh(-0.) is -0., or if platform doesn't have signed zeros])
fi
-AC_REPLACE_FUNCS(hypot)
-
-AC_CHECK_FUNCS([acosh asinh atanh copysign expm1 finite log1p])
+AC_CHECK_FUNCS([acosh asinh atanh copysign expm1 finite hypot log1p])
AC_CHECK_DECLS([isinf, isnan, isfinite], [], [], [[#include <math.h>]])
LIBS=$LIBS_SAVE