summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2003-06-14 14:46:38 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2003-06-14 14:46:38 (GMT)
commit368de8f17f60316402ce7d498bd9e1fcc759ea33 (patch)
tree44a2721fbf2c97ada2976d100631dc73331dba09 /configure.in
parent1867f244168b0f809c4b8796e374e68c21ba880f (diff)
downloadcpython-368de8f17f60316402ce7d498bd9e1fcc759ea33.zip
cpython-368de8f17f60316402ce7d498bd9e1fcc759ea33.tar.gz
cpython-368de8f17f60316402ce7d498bd9e1fcc759ea33.tar.bz2
Give a warning if SO is set. Fixes #610332.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 963c664..4021728 100644
--- a/configure.in
+++ b/configure.in
@@ -1140,6 +1140,17 @@ then
CYGWIN*) SO=.dll;;
*) SO=.so;;
esac
+else
+ # this might also be a termcap variable, see #610332
+ echo
+ echo '====================================================================='
+ echo '+ +'
+ echo '+ WARNING: You have set SO in your environment. +'
+ echo '+ Do you really mean to change the extension for shared libraries? +'
+ echo '+ Continuing in 10 seconds to let you to ponder. +'
+ echo '+ +'
+ echo '====================================================================='
+ sleep 10
fi
AC_MSG_RESULT($SO)
# LDSHARED is the ld *command* used to create shared library