summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorNeil Schemenauer <nascheme@enme.ucalgary.ca>2001-01-27 06:54:42 (GMT)
committerNeil Schemenauer <nascheme@enme.ucalgary.ca>2001-01-27 06:54:42 (GMT)
commit3ae1d0aa84e06214f50c6984ed6816e1659b2d28 (patch)
treea3bcfae342896b27690f91d6cecb423e1afc6878 /configure.in
parent547397c45b4c6334ac6e8ee713de012a05a4fe4a (diff)
downloadcpython-3ae1d0aa84e06214f50c6984ed6816e1659b2d28.zip
cpython-3ae1d0aa84e06214f50c6984ed6816e1659b2d28.tar.gz
cpython-3ae1d0aa84e06214f50c6984ed6816e1659b2d28.tar.bz2
Restore --with-suffix option. AC_EXEEXT doesn't aways do what the user wants
and an option is more friendly then manually setting a variable.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 78c07d6..554aa93 100644
--- a/configure.in
+++ b/configure.in
@@ -171,6 +171,14 @@ fi
AC_PROG_CC
AC_EXEEXT
+AC_MSG_CHECKING(for --with-suffix)
+AC_ARG_WITH(suffix, [ --with-suffix=.exe set executable suffix],[
+ case $withval in
+ no) EXEEXT=;;
+ yes) EXEEXT=.exe;;
+ *) EXEEXT=$withval;;
+ esac])
+AC_MSG_RESULT($EXEEXT)
case $MACHDEP in
bsdos*)