summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2009-11-19 17:15:31 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2009-11-19 17:15:31 (GMT)
commit3c1928a595ddb5d413c252804da45ee78ed68543 (patch)
tree243581015f1da968151a55d439c6f6d8efa6faf1 /configure.in
parent26afd485ce46b6143a8568bebf648ca0d3f525b2 (diff)
downloadcpython-3c1928a595ddb5d413c252804da45ee78ed68543.zip
cpython-3c1928a595ddb5d413c252804da45ee78ed68543.tar.gz
cpython-3c1928a595ddb5d413c252804da45ee78ed68543.tar.bz2
Merged revisions 76403 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r76403 | ronald.oussoren | 2009-11-19 17:25:21 +0100 (Thu, 19 Nov 2009) | 14 lines Fix for issue #7085 On MacOSX 10.6 the CoreFoundation framework must be initialized on the main thread, the constructor function in that framework will cause an SIGABRT when it is called on any other thread. Because a number of extension link (indirectly) to CoreFoundation and the Python core itself didn't the interpreter crashed when importing some extensions, such as _locale, on a secondary thread. This fix ensures that Python is linked to CoreFoundation on OSX, which results in the CoreFoundation constructor being called when Python is loaded. This does not require code changes. ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 2a0745f..ac63667 100644
--- a/configure.in
+++ b/configure.in
@@ -3853,6 +3853,10 @@ then
[Define to printf format modifier for long long type])
fi
+if test $ac_sys_system = Darwin
+then
+ LIBS="$LIBS -framework CoreFoundation"
+fi
AC_MSG_CHECKING(for %zd printf() format support)
AC_CACHE_VAL(ac_cv_have_size_t_format,