summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorHye-Shik Chang <hyeshik@gmail.com>2004-04-14 07:55:31 (GMT)
committerHye-Shik Chang <hyeshik@gmail.com>2004-04-14 07:55:31 (GMT)
commit54f9439b7c64dd2e59fcfbe8e6f7fcb7cb263628 (patch)
tree5c5a0caf9899c539b713de6445ac7cfefd8db9c1 /configure.in
parent0046839dd2ba66008749db724366f56c30ce25e9 (diff)
downloadcpython-54f9439b7c64dd2e59fcfbe8e6f7fcb7cb263628.zip
cpython-54f9439b7c64dd2e59fcfbe8e6f7fcb7cb263628.tar.gz
cpython-54f9439b7c64dd2e59fcfbe8e6f7fcb7cb263628.tar.bz2
Bug #934635: Fix a bug where the configure script couldn't detect
getaddrinfo() properly if the KAME stack had SCTP support. (Submitted by SUZUKI Shinsuke)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 46e290a..70f1109 100644
--- a/configure.in
+++ b/configure.in
@@ -2214,6 +2214,7 @@ main()
hints.ai_family = AF_UNSPEC;
hints.ai_flags = passive ? AI_PASSIVE : 0;
hints.ai_socktype = SOCK_STREAM;
+ hints.ai_protocol = IPPROTO_TCP;
if ((gaierr = getaddrinfo(NULL, "54321", &hints, &aitop)) != 0) {
(void)gai_strerror(gaierr);
goto bad;