summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMark Dickinson <dickinsm@gmail.com>2008-04-26 20:48:56 (GMT)
committerMark Dickinson <dickinsm@gmail.com>2008-04-26 20:48:56 (GMT)
commitb0e2b4c52f2464041f71bf3a78e53d8ecc5dc0df (patch)
tree755e716680b164ee4428fe2889b9302f5c6f0b2f /configure.in
parenta1e5325cf23135da36e1c55698c9d637bb8468e6 (diff)
downloadcpython-b0e2b4c52f2464041f71bf3a78e53d8ecc5dc0df.zip
cpython-b0e2b4c52f2464041f71bf3a78e53d8ecc5dc0df.tar.gz
cpython-b0e2b4c52f2464041f71bf3a78e53d8ecc5dc0df.tar.bz2
Merged revisions 62499 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r62499 | mark.dickinson | 2008-04-25 12:11:04 -0400 (Fri, 25 Apr 2008) | 7 lines Issue #1496032. Add -mieee to BASECFLAGS on alpha, when gcc is the compiler. This should(?) help to fix failures in test_math and test_cmath on Linux/alpha. Also add configure message reporting the result of uname -m, as a debugging aid. ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a1c044f..43d6ae0 100644
--- a/configure.in
+++ b/configure.in
@@ -333,6 +333,10 @@ AC_SUBST(EXPORT_MACOSX_DEPLOYMENT_TARGET)
CONFIGURE_MACOSX_DEPLOYMENT_TARGET=
EXPORT_MACOSX_DEPLOYMENT_TARGET='#'
+AC_MSG_CHECKING(machine type as reported by uname -m)
+ac_sys_machine=`uname -m`
+AC_MSG_RESULT($ac_sys_machine)
+
# checks for alternative programs
# compiler flags are generated in two sets, BASECFLAGS and OPT. OPT is just
@@ -792,6 +796,16 @@ yes)
then
BASECFLAGS="$BASECFLAGS -fno-strict-aliasing"
fi
+
+ # if using gcc on alpha, use -mieee to get (near) full IEEE 754
+ # support. Without this, treatment of subnormals doesn't follow
+ # the standard.
+ case $ac_sys_machine in
+ alpha*)
+ BASECFLAGS="$BASECFLAGS -mieee"
+ ;;
+ esac
+
case $ac_sys_system in
SCO_SV*)
BASECFLAGS="$BASECFLAGS -m486 -DSCO5"