summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBarry Warsaw <barry@python.org>2000-08-18 04:53:33 (GMT)
committerBarry Warsaw <barry@python.org>2000-08-18 04:53:33 (GMT)
commitbc7c7f991c4654cb270cc09272559534de492d30 (patch)
tree45320b5090ddbf687b3cb3c3e88e3ff7ee641f5d /configure.in
parente736177d5bfdb0e7e844b199c4637991ed9dda49 (diff)
downloadcpython-bc7c7f991c4654cb270cc09272559534de492d30.zip
cpython-bc7c7f991c4654cb270cc09272559534de492d30.tar.gz
cpython-bc7c7f991c4654cb270cc09272559534de492d30.tar.bz2
Added test for uintptr_t, the C9X acceptable way to spell "type to
which I can cast void* to and back again without losing information". In pyport.h, we typedef Py_uintptr_t to mean this thing, which if the platform supports, will be uintptr_t (otherwise, other accomodations are made).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index aeb3223..b8371f8 100644
--- a/configure.in
+++ b/configure.in
@@ -399,6 +399,14 @@ if test "$have_long_long" = yes ; then
AC_CHECK_SIZEOF(long long)
fi
+AC_MSG_CHECKING(for uintptr_t support)
+have_uintptr_t=no
+AC_TRY_COMPILE([], [uintptr_t x; x = (uintptr_t)0;], AC_DEFINE(HAVE_UINTPTR_T) have_uintptr_t=yes)
+AC_MSG_RESULT($have_uintptr_t)
+if test "$have_uintptr_t" = yes ; then
+AC_CHECK_SIZEOF(uintptr_t)
+fi
+
# Hmph. AC_CHECK_SIZEOF() doesn't include <sys/types.h>.
AC_MSG_CHECKING(size of off_t)
AC_CACHE_VAL(ac_cv_sizeof_off_t,