summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2001-06-19 15:00:23 (GMT)
committerJack Jansen <jack.jansen@cwi.nl>2001-06-19 15:00:23 (GMT)
commitc49e5b7386e3019b539d6b37f107055f3e507a62 (patch)
treed3a71d37f8dbf038f638b44b7dad8d76966d39de /configure.in
parent82ac8d13ff4b6470400a4b639fdab398183fdbbc (diff)
downloadcpython-c49e5b7386e3019b539d6b37f107055f3e507a62.zip
cpython-c49e5b7386e3019b539d6b37f107055f3e507a62.tar.gz
cpython-c49e5b7386e3019b539d6b37f107055f3e507a62.tar.bz2
Added a MACHDEP_OBJS to the python link. Use this on MacOSX to include
Mac/macglue.c into the core interpreter. This file contains the glue code that allows extension modules for Mac toolboxes to live in different shared libraries but still communicate with each other. The glue code is controlled by the USE_MAC_TOOLBOX_GLUE define.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 17 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 890aae2..561c104 100644
--- a/configure.in
+++ b/configure.in
@@ -677,7 +677,7 @@ then
# crt1.o) gets erroneously defined as common, which breaks dynamic
# loading of any modules which reference it in System.framework
next/4*|next/5*) LINKFORSHARED="-u __dummy -framework System" ;;
- Darwin/*) LINKFORSHARED="-u __dummy -framework System -framework Foundation" ;;
+ Darwin/*) LINKFORSHARED="-u __dummy -u _PyMac_Error -framework System -framework Foundation -framework Carbon" ;;
UnixWare*) LINKFORSHARED="-dy -Bdynamic -Wl,-Bexport";;
SCO_SV*) LINKFORSHARED="-Bdynamic -dy -Wl,-Bexport";;
ReliantUNIX*) LINKFORSHARED="-W1 -Blargedynsym";;
@@ -997,6 +997,22 @@ then
AC_DEFINE(HAVE_DYNAMIC_LOADING)
fi
+# MACHDEP_OBJS can be set to platform-specific object files needed by Python
+
+AC_SUBST(MACHDEP_OBJS)
+AC_MSG_CHECKING(MACHDEP_OBJS)
+if test -z "$MACHDEP_OBJS"
+then
+ case $ac_sys_system/$ac_sys_release in
+ Darwin/*)
+ MACHDEP_OBJS="Mac/Python/macglue.o"
+ AC_DEFINE(USE_TOOLBOX_OBJECT_GLUE)
+ ;;
+ *) MACHDEP_OBJS="";;
+ esac
+fi
+AC_MSG_RESULT($DYNLOADFILE)
+
# checks for library functions
AC_CHECK_FUNCS(alarm chown clock confstr ctermid ctermid_r execv \
flock fork fsync fdatasync fpathconf ftime ftruncate \