summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSkip Montanaro <skip@pobox.com>2004-01-17 14:19:44 (GMT)
committerSkip Montanaro <skip@pobox.com>2004-01-17 14:19:44 (GMT)
commitce59c04127cb82127e247f5e986b07cbb6c39c61 (patch)
tree75b910d56a7b8f039e99c2cf6156c061124ef1e8 /configure.in
parent09de7567269af82164ec7dd0c5edf3ec6d1b7502 (diff)
downloadcpython-ce59c04127cb82127e247f5e986b07cbb6c39c61.zip
cpython-ce59c04127cb82127e247f5e986b07cbb6c39c61.tar.gz
cpython-ce59c04127cb82127e247f5e986b07cbb6c39c61.tar.bz2
Remove support for SunOS 4.
Remove BAD_EXEC_PROTOYPE (leftover from IRIX 4 demolition).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 2 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index 31805c1..c4b60f7 100644
--- a/configure.in
+++ b/configure.in
@@ -332,7 +332,7 @@ AC_AIX
# Check for unsupported systems
case $ac_sys_system/$ac_sys_release in
-SunOS/4*|Linux*/1*)
+Linux*/1*)
echo This system \($ac_sys_system/$ac_sys_release\) is no longer supported.
echo See README for details.
exit 1;;
@@ -1221,7 +1221,7 @@ else
fi
AC_MSG_RESULT($SO)
# LDSHARED is the ld *command* used to create shared library
-# -- "ld" on SunOS 4.x.x, "cc -G" on SunOS 5.x, "ld -shared" on IRIX 5
+# -- "cc -G" on SunOS 5.x, "ld -shared" on IRIX 5
# (Shared libraries in this instance are shared modules to be loaded into
# Python, as opposed to building Python itself as a shared library.)
AC_MSG_CHECKING(LDSHARED)
@@ -1238,7 +1238,6 @@ then
;;
IRIX/5*) LDSHARED="ld -shared";;
IRIX*/6*) LDSHARED="ld ${SGI_ABI} -shared -all";;
- SunOS/4*) LDSHARED="ld";;
SunOS/5*)
if test "$GCC" = "yes"
then LDSHARED='$(CC) -shared'
@@ -2426,18 +2425,6 @@ int foo(int x, ...) {
])
AC_MSG_RESULT($works)
-if test "$have_prototypes" = yes; then
-bad_prototypes=no
-AC_MSG_CHECKING(for bad exec* prototypes)
-AC_TRY_COMPILE([#include <unistd.h>], [char **t;execve("@",t,t);], ,
- AC_DEFINE(BAD_EXEC_PROTOTYPES, 1,
- [Define if your <unistd.h> contains bad prototypes for exec*()
- (as it does on SGI IRIX 4.x)])
- bad_prototypes=yes
-)
-AC_MSG_RESULT($bad_prototypes)
-fi
-
# check if sockaddr has sa_len member
AC_MSG_CHECKING(if sockaddr has sa_len member)
AC_TRY_COMPILE([#include <sys/types.h>