summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>2000-09-22 19:41:56 (GMT)
committerGuido van Rossum <guido@python.org>2000-09-22 19:41:56 (GMT)
commite126233cd984d33644d26227842cf6f4360446d9 (patch)
tree61db472230e541f497acc3f49b202c9bc5b2a57f /configure.in
parentd9a8dec1356e19798492c2abb945c22f00299f33 (diff)
downloadcpython-e126233cd984d33644d26227842cf6f4360446d9.zip
cpython-e126233cd984d33644d26227842cf6f4360446d9.tar.gz
cpython-e126233cd984d33644d26227842cf6f4360446d9.tar.bz2
Poke-and-hope attempt to fix Bugs #115006 and #114324: fix the test
for pthread_t (to calculate its size) to work even if pthread_t is a struct.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 1bf8854..0824a92 100644
--- a/configure.in
+++ b/configure.in
@@ -170,7 +170,7 @@ AC_ARG_WITH(cxx, [ --with-cxx=<compiler> enable C++ support],[
with_cxx=no
])
AC_MSG_RESULT($with_cxx)
-SET_CXX="CXX = $CXX"
+SET_CXX="CXX=$CXX"
#AC_MSG_CHECKING(CCC)
#if test -z "$CCC"
@@ -477,7 +477,7 @@ AC_DEFINE_UNQUOTED(SIZEOF_TIME_T, $ac_cv_sizeof_time_t)
# if have pthread_t then define SIZEOF_PTHREAD_T
AC_MSG_CHECKING(for pthread_t)
have_pthread_t=no
-AC_TRY_COMPILE([#include <pthread.h>], [pthread_t x; x = (pthread_t)0;], have_pthread_t=yes)
+AC_TRY_COMPILE([#include <pthread.h>], [pthread_t x; x = *(pthread_t)*0;], have_pthread_t=yes)
AC_MSG_RESULT($have_pthread_t)
if test "$have_pthread_t" = yes ; then
# AC_CHECK_SIZEOF() doesn't include <pthread.h>.