summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2006-10-02 14:55:51 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2006-10-02 14:55:51 (GMT)
commitebe26709d2c5c6b633071acc9565ca6116cd0a55 (patch)
tree1a92a7bf94975611176b49d2727d8d65705ac7f1 /configure.in
parente0b673573b7e94420b147cf28241091f4fe2fcff (diff)
downloadcpython-ebe26709d2c5c6b633071acc9565ca6116cd0a55.zip
cpython-ebe26709d2c5c6b633071acc9565ca6116cd0a55.tar.gz
cpython-ebe26709d2c5c6b633071acc9565ca6116cd0a55.tar.bz2
Fix test for uintptr_t. Fixes #1568842.
Will backport.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 4 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 3a27294..6fd8fdf 100644
--- a/configure.in
+++ b/configure.in
@@ -1197,16 +1197,10 @@ if test "$have_long_long" = yes ; then
AC_CHECK_SIZEOF(long long, 8)
fi
-AC_MSG_CHECKING(for uintptr_t support)
-have_uintptr_t=no
-AC_TRY_COMPILE([], [uintptr_t x; x = (uintptr_t)0;], [
- AC_DEFINE(HAVE_UINTPTR_T, 1, [Define this if you have the type uintptr_t.])
- have_uintptr_t=yes
-])
-AC_MSG_RESULT($have_uintptr_t)
-if test "$have_uintptr_t" = yes ; then
-AC_CHECK_SIZEOF(uintptr_t, 4)
-fi
+AC_CHECK_TYPES(uintptr_t,
+ [AC_CHECK_SIZEOF(uintptr_t, 4)],
+ [], [#include <stdint.h>])
+
# Hmph. AC_CHECK_SIZEOF() doesn't include <sys/types.h>.
AC_MSG_CHECKING(size of off_t)