summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>1997-12-04 00:51:42 (GMT)
committerGuido van Rossum <guido@python.org>1997-12-04 00:51:42 (GMT)
commit009f78754db89ab0ace3175876ab7fa88a445c8a (patch)
tree923408c41d9a746cff037b1d8695d1cb9785bcdd /configure.in
parenta0cbb3dbae487b5cb1aef4345740725f817faf98 (diff)
downloadcpython-009f78754db89ab0ace3175876ab7fa88a445c8a.zip
cpython-009f78754db89ab0ace3175876ab7fa88a445c8a.tar.gz
cpython-009f78754db89ab0ace3175876ab7fa88a445c8a.tar.bz2
When --with-thread(s) is specified, the thread module is now automatically
enabled. This is done through a substitution in Modules/Setup.thread(.in). Bill Janssen will be happy. The original idea was by Lele Gaifax (though I changed the implementation to use a separate file).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index c7bd276..093bd73 100644
--- a/configure.in
+++ b/configure.in
@@ -348,6 +348,9 @@ AC_ARG_WITH(readline,
AC_ERROR(--with(out)-readline is obsolete, edit Modules/Setup instead)],
[AC_MSG_RESULT(not specified.)])
+AC_SUBST(USE_THREAD_MODULE)
+USE_THREAD_MODULE="#"
+
AC_MSG_CHECKING(for --with-dec-threads)
AC_SUBST(LDLAST)
AC_ARG_WITH(dec-threads,
@@ -369,6 +372,7 @@ AC_MSG_RESULT(no))
AC_MSG_CHECKING(for --with-thread)
AC_ARG_WITH(thread, [--with-thread[=DIRECTORY] make interpreter thread-safe], [
+USE_THREAD_MODULE=
AC_MSG_RESULT($withval)
if test -d "$withval"
then LDFLAGS="$LDFLAGS -L$withval"
@@ -642,4 +646,5 @@ AC_OUTPUT(Makefile \
Objects/Makefile \
Parser/Makefile \
Python/Makefile \
- Modules/Makefile.pre)
+ Modules/Makefile.pre \
+ Modules/Setup.thread)