summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorStefan Krah <skrah@bytereef.org>2011-09-14 13:17:12 (GMT)
committerStefan Krah <skrah@bytereef.org>2011-09-14 13:17:12 (GMT)
commit66611c554d074ccff4c7b152c305e09bbd8e636a (patch)
tree3add532bba3e8fdd9488b7bc4c1955c0a4e512aa /configure.in
parentb77fe173203139af07eaee17c3540ae8fdd3a672 (diff)
parent962055d3c658e9b2e75ba4c3682c3639eea9aed8 (diff)
downloadcpython-66611c554d074ccff4c7b152c305e09bbd8e636a.zip
cpython-66611c554d074ccff4c7b152c305e09bbd8e636a.tar.gz
cpython-66611c554d074ccff4c7b152c305e09bbd8e636a.tar.bz2
Merge fix for issue #11149.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5a16bb0..315a832 100644
--- a/configure.in
+++ b/configure.in
@@ -905,6 +905,12 @@ then
if "$CC" -v --help 2>/dev/null |grep -- -fwrapv > /dev/null; then
WRAP="-fwrapv"
fi
+
+ # Clang also needs -fwrapv
+ if test "$CC" = "clang" ; then
+ WRAP="-fwrapv"
+ fi
+
case $ac_cv_prog_cc_g in
yes)
if test "$Py_DEBUG" = 'true' ; then