summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAntoine Pitrou <solipsis@pitrou.net>2009-10-24 20:35:52 (GMT)
committerAntoine Pitrou <solipsis@pitrou.net>2009-10-24 20:35:52 (GMT)
commitdb6c567a720da3a71dd41671d4ceddf8300dc298 (patch)
tree59bd0d433c70e1cbcbe40ab925c06aeba663d01a /configure.in
parent1b8c7834086975a5aae08f36cd1cceb39c5d4a84 (diff)
downloadcpython-db6c567a720da3a71dd41671d4ceddf8300dc298.zip
cpython-db6c567a720da3a71dd41671d4ceddf8300dc298.tar.gz
cpython-db6c567a720da3a71dd41671d4ceddf8300dc298.tar.bz2
Disable GNU pth support
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 1 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index 41f470b..23d3ee4 100644
--- a/configure.in
+++ b/configure.in
@@ -2018,17 +2018,6 @@ yes
AC_DEFINE(MACH_C_THREADS, 1,
[Define if you are using Mach cthreads under mach /])
THREADOBJ="Python/thread.o"],[
- AC_MSG_CHECKING(for --with-pth)
- AC_ARG_WITH([pth],
- AC_HELP_STRING(--with-pth, use GNU pth threading libraries),
- [AC_MSG_RESULT($withval)
- AC_DEFINE([WITH_THREAD])
- AC_DEFINE([HAVE_PTH], 1,
- [Define if you have GNU PTH threads.])
- LIBS="-lpth $LIBS"
- THREADOBJ="Python/thread.o"],
- [AC_MSG_RESULT(no)
-
# Just looking for pthread_create in libpthread is not enough:
# on HP/UX, pthread.h renames pthread_create to a different symbol name.
# So we really have to include pthread.h, and then link.
@@ -2064,7 +2053,7 @@ pthread_create (NULL, NULL, start_routine, NULL)], [
LIBS="$LIBS -lcma"
THREADOBJ="Python/thread.o"],[
USE_THREAD_MODULE="#"])
- ])])])])])])])])
+ ])])])])])])])
AC_CHECK_LIB(mpc, usconfig, [AC_DEFINE(WITH_THREAD)
LIBS="$LIBS -lmpc"