summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlexandre Vassalotti <alexandre@peadrop.com>2009-07-17 06:41:02 (GMT)
committerAlexandre Vassalotti <alexandre@peadrop.com>2009-07-17 06:41:02 (GMT)
commite5091f6c5a8c5120588543661fb9abb3ec46eb43 (patch)
tree055f5a646527526e879cc46e0fc565f325dcbada /configure.in
parentaee170aaed7010441ad992222881e56048877cf1 (diff)
downloadcpython-e5091f6c5a8c5120588543661fb9abb3ec46eb43.zip
cpython-e5091f6c5a8c5120588543661fb9abb3ec46eb43.tar.gz
cpython-e5091f6c5a8c5120588543661fb9abb3ec46eb43.tar.bz2
Merged revisions 74044 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r74044 | alexandre.vassalotti | 2009-07-17 02:33:51 -0400 (Fri, 17 Jul 2009) | 3 lines Double-quote the test case for %zd printf() format support to avoid mangling the array declarations in it. ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 17b89b0..2876eb9 100644
--- a/configure.in
+++ b/configure.in
@@ -3771,7 +3771,8 @@ fi
AC_MSG_CHECKING(for %zd printf() format support)
AC_CACHE_VAL(ac_cv_have_size_t_format,
-AC_TRY_RUN([#include <stdio.h>
+AC_TRY_RUN([[
+#include <stdio.h>
#include <stddef.h>
#include <string.h>
@@ -3805,9 +3806,9 @@ int main()
return 0;
}
-], ac_cv_have_size_t_format=yes,
- ac_cv_have_size_t_format=no,
- ac_cv_have_size_t_format=no)
+]], ac_cv_have_size_t_format=yes,
+ ac_cv_have_size_t_format=no,
+ ac_cv_have_size_t_format=no)
)
AC_MSG_RESULT($ac_cv_have_size_t_format)
if test $ac_cv_have_size_t_format = yes