summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGeorg Brandl <georg@python.org>2011-03-06 09:26:32 (GMT)
committerGeorg Brandl <georg@python.org>2011-03-06 09:26:32 (GMT)
commitfe09a54280a56a01402f4cb98c8c6cb4be89654a (patch)
tree7bea7a6d99ae4509b5f77fca934ec32f8a93c8ab /configure.in
parentf874debbf37636b0f2f46f8db06be50c20b670a8 (diff)
parent13039c87f14aeed325bcb5fadd202922a614957b (diff)
downloadcpython-fe09a54280a56a01402f4cb98c8c6cb4be89654a.zip
cpython-fe09a54280a56a01402f4cb98c8c6cb4be89654a.tar.gz
cpython-fe09a54280a56a01402f4cb98c8c6cb4be89654a.tar.bz2
Merge build identification to default branch.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5476250..5eae5e7 100644
--- a/configure.in
+++ b/configure.in
@@ -810,6 +810,21 @@ else
SVNVERSION="echo Unversioned directory"
fi
+AC_SUBST(HGVERSION)
+AC_SUBST(HGTAG)
+AC_SUBST(HGBRANCH)
+AC_CHECK_PROG(HAS_HG, hg, found, not-found)
+if test $HAS_HG = found
+then
+ HGVERSION="hg id -i \$(srcdir)"
+ HGTAG="hg id -t \$(srcdir)"
+ HGBRANCH="hg id -b \$(srcdir)"
+else
+ HGVERSION=""
+ HGTAG=""
+ HGBRANCH=""
+fi
+
case $MACHDEP in
bsdos*|hp*|HP*)
# install -d does not work on BSDI or HP-UX