summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2000-09-24 19:40:25 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2000-09-24 19:40:25 (GMT)
commit05a65d6745067f65105918d687fb8ab7153068a3 (patch)
tree672c5f1bf506f18c96cff2b3f2edcb85e0980551 /configure.in
parent716efea1810be1b5cf1b10979197744504250adc (diff)
downloadcpython-05a65d6745067f65105918d687fb8ab7153068a3.zip
cpython-05a65d6745067f65105918d687fb8ab7153068a3.tar.gz
cpython-05a65d6745067f65105918d687fb8ab7153068a3.tar.bz2
If dbopen is not in libc, checking whether it is in libdb will fail if
db_185.h has renamed that function to __db185_open, which it does in DB 3.1. So don't check whether the function is in -ldb.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e276c6f..e0cd8fc 100644
--- a/configure.in
+++ b/configure.in
@@ -855,7 +855,11 @@ if test "$with_libdb" = "yes"
then
# check for libdb; BSD systems have the DB routines in libc --tg
AC_SUBST(HAVE_LIBDB)
- AC_CHECK_FUNC(dbopen, [HAVE_LIBDB=], AC_CHECK_LIB(db, dbopen, [HAVE_LIBDB=-ldb]))
+ # If dbopen is not in libc, then checking whether it is in libdb
+ # is difficult: db_185.h may #define it as __db185_open
+ # Instead, we just trust it is in libdb; linking will fail if it
+ # is not.
+ AC_CHECK_FUNC(dbopen, [HAVE_LIBDB=], [HAVE_LIBDB=-ldb])
fi
# Check for --with-wctype-functions