summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorNeal Norwitz <nnorwitz@gmail.com>2003-03-31 15:53:49 (GMT)
committerNeal Norwitz <nnorwitz@gmail.com>2003-03-31 15:53:49 (GMT)
commit0b27ff92d2127ed39f52d9987e4e96313937cbc8 (patch)
tree4ff172e7da1f1f0f233854f279d7f50850961eed /configure.in
parentaca44e277170fed72668ba18430c8b53c7f6f499 (diff)
downloadcpython-0b27ff92d2127ed39f52d9987e4e96313937cbc8.zip
cpython-0b27ff92d2127ed39f52d9987e4e96313937cbc8.tar.gz
cpython-0b27ff92d2127ed39f52d9987e4e96313937cbc8.tar.bz2
SF patch #712367, get build working on AIX
configure change is necessary to pass "." to makexp_aix so that dynamic modules work setup change gets curses working
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 5f455c1..34c7238 100644
--- a/configure.in
+++ b/configure.in
@@ -421,7 +421,12 @@ then
fi
case $ac_sys_system in
AIX*)
- LINKCC="\$(srcdir)/Modules/makexp_aix Modules/python.exp \"\" \$(LIBRARY); $LINKCC";;
+ exp_extra="\"\""
+ if test $ac_sys_release -ge 5 -o \
+ $ac_sys_release -eq 4 -a `uname -r` -ge 2 ; then
+ exp_extra="."
+ fi
+ LINKCC="\$(srcdir)/Modules/makexp_aix Modules/python.exp $exp_extra \$(LIBRARY); $LINKCC";;
dgux*)
LINKCC="LD_RUN_PATH=$libdir $LINKCC";;
Monterey64*)