summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2003-03-29 22:07:47 (GMT)
committerJack Jansen <jack.jansen@cwi.nl>2003-03-29 22:07:47 (GMT)
commit150753cb22cc29041b8796f26270cbc071b06741 (patch)
treee9009f913d2b95a0c14ecf1a55d30bb2678a92c1 /configure.in
parent7035c98c5c0eec7f88fab146e72b2a7e4aaf64a5 (diff)
downloadcpython-150753cb22cc29041b8796f26270cbc071b06741.zip
cpython-150753cb22cc29041b8796f26270cbc071b06741.tar.gz
cpython-150753cb22cc29041b8796f26270cbc071b06741.tar.bz2
The test for setpgrp having two arguments didn't actually test anything.
For reasons unknown this suddenly started to matter (since Martin's 1.396 checkin? But why?), at least on MacOSX. Added a real test similar to the getpgrp argument test.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index ed1ee95..4378838 100644
--- a/configure.in
+++ b/configure.in
@@ -1925,8 +1925,12 @@ AC_CHECK_FUNCS(getpgrp,
[Define if getpgrp() must be called as getpgrp(0).])
)
)
-AC_FUNC_SETPGRP(AC_DEFINE(SETPGRP_HAVE_ARG, 1,
- [Define if setpgrp() must be called as setpgrp(0, 0).])
+AC_CHECK_FUNCS(setpgrp,
+ AC_TRY_COMPILE([#include <unistd.h>],
+ [setpgrp(0,0);],
+ AC_DEFINE(SETPGRP_HAVE_ARG, 1,
+ [Define if setpgrp() must be called as setpgrp(0, 0).])
+ )
)
AC_CHECK_FUNCS(gettimeofday,
AC_TRY_COMPILE([#include <sys/time.h>],