summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>2001-01-10 18:53:48 (GMT)
committerGuido van Rossum <guido@python.org>2001-01-10 18:53:48 (GMT)
commit3d15bd88063019352d11382f5d1b36b6845f65dc (patch)
treeb7f0e74ce9183915fc99d7fd05cd1e5438a6e97a /configure.in
parent3559d1f9b3f33b45de924f5d17dcea6ab949bb41 (diff)
downloadcpython-3d15bd88063019352d11382f5d1b36b6845f65dc.zip
cpython-3d15bd88063019352d11382f5d1b36b6845f65dc.tar.gz
cpython-3d15bd88063019352d11382f5d1b36b6845f65dc.tar.bz2
Adapted version of Eric Raymond's patches to automatically configure
curses and readline (for Linux, at least). These are done as shared libraries by default, and so is bsddb -- that seems to make the most sense.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a27a6ed..34e456c 100644
--- a/configure.in
+++ b/configure.in
@@ -734,6 +734,21 @@ AC_MSG_RESULT($withval)
LIBS="$withval $LIBS"
], AC_MSG_RESULT(no))
+# This is used to generate Setup.config
+AC_SUBST(USE_NCURSES_MODULE)
+AC_CHECK_LIB(ncurses, initscr,
+ [USE_NCURSES_MODULE=""],
+ [USE_NCURSES_MODULE="#"],
+ -ltermcap)
+
+# This is used to generate Setup.config
+AC_SUBST(USE_READLINE_MODULE)
+AC_CHECK_LIB(readline, readline,
+ [USE_READLINE_MODULE=""],
+ [USE_READLINE_MODULE="#"],
+ -ltermcap)
+
+# This is used to generate Setup.config
AC_SUBST(USE_THREAD_MODULE)
USE_THREAD_MODULE=""