summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>2001-01-10 20:40:46 (GMT)
committerGuido van Rossum <guido@python.org>2001-01-10 20:40:46 (GMT)
commit4c3f57cf05c9d7ea5b1ff681703b95ce034f16c3 (patch)
tree1f6977ba86b4e8ca7dff69e3161bdb386a486bec /configure.in
parentf61f166bca4f17c1199c12184ebc41755c0fb8e0 (diff)
downloadcpython-4c3f57cf05c9d7ea5b1ff681703b95ce034f16c3.zip
cpython-4c3f57cf05c9d7ea5b1ff681703b95ce034f16c3.tar.gz
cpython-4c3f57cf05c9d7ea5b1ff681703b95ce034f16c3.tar.bz2
SF Patch #103154 by jlt63: Cygwin Check Import Case Patch.
Note: I've reordered acconfig.h and config.h.in to obtain alphabetical order (modulo case and leading _).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 34e456c..fe0d496 100644
--- a/configure.in
+++ b/configure.in
@@ -1232,6 +1232,18 @@ else AC_ERROR(proper usage is --with-libc=STRING)
fi],
[AC_MSG_RESULT(default LIBC=\"$LIBC\")])
+# check for --with-check-import-case
+AC_ARG_WITH(check-import-case,
+[ --with-check-import-case enable imported module name case checking],,)
+AC_MSG_CHECKING(for --with-check-import-case)
+if test "$with_check_import_case"
+then
+ AC_DEFINE(CHECK_IMPORT_CASE)
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+fi
+
# check for hypot() in math library
LIBS_SAVE=$LIBS
LIBS="$LIBS $LIBM"