summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMichael W. Hudson <mwh@python.net>2001-12-07 15:38:26 (GMT)
committerMichael W. Hudson <mwh@python.net>2001-12-07 15:38:26 (GMT)
commit542411384c8a6a31525dc74a46014d6af9c59efa (patch)
tree866bd6c315152ff08b4311faa5713b93bbb5c6d8 /configure.in
parent0702858d733e1ab37e3e7bb6258557fd7aca3d10 (diff)
downloadcpython-542411384c8a6a31525dc74a46014d6af9c59efa.zip
cpython-542411384c8a6a31525dc74a46014d6af9c59efa.tar.gz
cpython-542411384c8a6a31525dc74a46014d6af9c59efa.tar.bz2
Fix for:
[ #417634 ] configuring without C++ compiler name by checking that we're not about to try to compile C++ files with "yes". Now we wait for the system where the C++ compiler *is* called yes...
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0dd7e0a..15f5ee1 100644
--- a/configure.in
+++ b/configure.in
@@ -151,6 +151,11 @@ AC_ARG_WITH(cxx, [ --with-cxx=<compiler> enable C++ support],[
])
AC_MSG_RESULT($with_cxx)
+if test "$with_cxx" = "yes"
+then
+ AC_ERROR(must supply a compiler when using --with-cxx)
+fi
+
dnl The following fragment works similar to AC_PROG_CXX.
dnl It does not fail if CXX is not found, and it is not executed if
dnl --without-cxx was given.