summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2003-07-04 12:14:39 (GMT)
committerJack Jansen <jack.jansen@cwi.nl>2003-07-04 12:14:39 (GMT)
commit66b84832477258a009dbc011f1ac20a42495d220 (patch)
tree803df4492698c700ec74ce850f39b6738ae444f4 /configure.in
parent276b2900b813745801cf08c73169cf0fcd0fa75a (diff)
downloadcpython-66b84832477258a009dbc011f1ac20a42495d220.zip
cpython-66b84832477258a009dbc011f1ac20a42495d220.tar.gz
cpython-66b84832477258a009dbc011f1ac20a42495d220.tar.bz2
Fixed two bugs in MacOSX framework handling spotted by Edward Moy:
- In the top level Makefile, the argument to -install_name should be prepended with /System/Library/Frameworks/, so it is an absolute path. - In the top level Makefile, because of 2), RUNSHARED needs to be set to DYLD_FRAMEWORK_PATH=<path to local framework> and $(RUNSHARED) prepended to the $(MAKE) lines in the frameworkinstallmaclib and frameworkinstallapps targets.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index b80086c..b82ca6e 100644
--- a/configure.in
+++ b/configure.in
@@ -487,7 +487,7 @@ AC_MSG_CHECKING(LDLIBRARY)
if test "$enable_framework"
then
LDLIBRARY='$(PYTHONFRAMEWORKDIR)/Versions/$(VERSION)/$(PYTHONFRAMEWORK)'
- LDLIBRARYDIR='$(PYTHONFRAMEWORKDIR)'
+ RUNSHARED=DYLD_FRAMEWORK_PATH="`pwd`:$DYLD_FRAMEWORK_PATH"
BLDLIBRARY=''
else
BLDLIBRARY='$(LDLIBRARY)'
@@ -1132,12 +1132,12 @@ case $ac_sys_system/$ac_sys_release in
Darwin/1.3*)
LIBTOOL_CRUFT="-lcc_dynamic -arch_only ppc"
LIBTOOL_CRUFT="$LIBTOOL_CRUFT $extra_frameworks"
- LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -install_name $(PYTHONFRAMEWORKDIR)/Versions/$(VERSION)/Python'
+ LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -install_name $(PYTHONFRAMEWORKINSTALLDIR)/Versions/$(VERSION)/Python'
LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -compatibility_version $(VERSION) -current_version $(VERSION)';;
Darwin/*)
LIBTOOL_CRUFT="-lcc_dynamic -arch_only ppc"
LIBTOOL_CRUFT="$LIBTOOL_CRUFT $extra_frameworks"
- LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -install_name $(PYTHONFRAMEWORKDIR)/Versions/$(VERSION)/Python'
+ LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -install_name $(PYTHONFRAMEWORKINSTALLDIR)/Versions/$(VERSION)/Python'
LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -compatibility_version $(VERSION) -current_version $(VERSION)';;
esac