summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorNeal Norwitz <nnorwitz@gmail.com>2003-02-23 23:28:15 (GMT)
committerNeal Norwitz <nnorwitz@gmail.com>2003-02-23 23:28:15 (GMT)
commit6eb37f0eea47842f776c144f70d3c0dfbc2dabfe (patch)
tree92378a07ff23e27553b5301b5f7a1f5d25a333ff /configure.in
parent8cd9a4fded8e6b7451e47c36585ef3d2a318dcc8 (diff)
downloadcpython-6eb37f0eea47842f776c144f70d3c0dfbc2dabfe.zip
cpython-6eb37f0eea47842f776c144f70d3c0dfbc2dabfe.tar.gz
cpython-6eb37f0eea47842f776c144f70d3c0dfbc2dabfe.tar.bz2
Fix SF bug #691793, Python 2.3a2 build fails on Tru64
Need to make sure that preprocessor directives start in first column. This means we can't indent code which has preprocessor directives, nor have a space between [ #include for example.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in31
1 files changed, 16 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index 06c4048..1fc6bf7 100644
--- a/configure.in
+++ b/configure.in
@@ -763,15 +763,15 @@ AC_MSG_RESULT($was_it_defined)
# Check whether using makedev requires defining _OSF_SOURCE
AC_MSG_CHECKING(for makedev)
-AC_TRY_LINK([ #include <sys/types.h> ],
+AC_TRY_LINK([#include <sys/types.h> ],
[ makedev(0, 0) ],
ac_cv_has_makedev=yes,
ac_cv_has_makedev=no)
if test "$ac_cv_has_makedev" = "no"; then
# we didn't link, try if _OSF_SOURCE will allow us to link
AC_TRY_LINK([
- #define _OSF_SOURCE 1
- #include <sys/types.h>
+#define _OSF_SOURCE 1
+#include <sys/types.h>
],
[ makedev(0, 0) ],
ac_cv_has_makedev=yes,
@@ -929,7 +929,7 @@ if test "$have_pthread_t" = yes ; then
AC_MSG_CHECKING(size of pthread_t)
AC_CACHE_VAL(ac_cv_sizeof_pthread_t,
[AC_TRY_RUN([#include <stdio.h>
- #include <pthread.h>
+#include <pthread.h>
main()
{
FILE *f=fopen("conftestval", "w");
@@ -1357,10 +1357,11 @@ else
# define _POSIX_THREADS in unistd.h. Some apparently don't (which ones?)
AC_MSG_CHECKING(for _POSIX_THREADS in unistd.h)
AC_EGREP_CPP(yes,
- [#include <unistd.h>
- #ifdef _POSIX_THREADS
- yes
- #endif
+ [
+#include <unistd.h>
+#ifdef _POSIX_THREADS
+yes
+#endif
], unistd_defines_pthreads=yes, unistd_defines_pthreads=no)
AC_MSG_RESULT($unistd_defines_pthreads)
@@ -1927,13 +1928,13 @@ AC_CHECK_FUNCS(gettimeofday,
AC_MSG_CHECKING(for major, minor, and makedev)
AC_TRY_LINK([
- #if defined(MAJOR_IN_MKDEV)
- #include <sys/mkdev.h>
- #elif defined(MAJOR_IN_SYSMACROS)
- #include <sys/sysmacros.h>
- #else
- #include <sys/types.h>
- #endif
+#if defined(MAJOR_IN_MKDEV)
+#include <sys/mkdev.h>
+#elif defined(MAJOR_IN_SYSMACROS)
+#include <sys/sysmacros.h>
+#else
+#include <sys/types.h>
+#endif
],[
makedev(major(0),minor(0));
],[