summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2005-11-26 11:38:24 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2005-11-26 11:38:24 (GMT)
commit7dece6690e103d24696ef543f7d14a2287c80446 (patch)
tree08e5cd86c932a1f7c9603f7eefc64b8ee49be6e9 /configure.in
parentd4bfe2c878746acbd18a62baebe72be6e24e5634 (diff)
downloadcpython-7dece6690e103d24696ef543f7d14a2287c80446.zip
cpython-7dece6690e103d24696ef543f7d14a2287c80446.tar.gz
cpython-7dece6690e103d24696ef543f7d14a2287c80446.tar.bz2
Patch #1227966: Do not defined _XOPEN_SOURCE_EXTENDED on Solaris 10.
Also set _XOPEN_SOURCE to 500. Will backport to 2.4.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 13 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 15a2a06..75a33a1 100644
--- a/configure.in
+++ b/configure.in
@@ -183,8 +183,10 @@ if test $define_xopen_source = yes
then
# On Solaris w/ g++ it appears that _XOPEN_SOURCE has to be
# defined precisely as g++ defines it
+ # Furthermore, on Solaris 10, XPG6 requires the use of a C99
+ # compiler
case $ac_sys_system/$ac_sys_release in
- SunOS/5.8|SunOS/5.9)
+ SunOS/5.8|SunOS/5.9|SunOS/5.10)
AC_DEFINE(_XOPEN_SOURCE, 500,
Define to the level of X/Open that your system supports)
;;
@@ -198,8 +200,16 @@ then
# definition of _XOPEN_SOURCE_EXTENDED and _POSIX_C_SOURCE, or else
# several APIs are not declared. Since this is also needed in some
# cases for HP-UX, we define it globally.
-
- AC_DEFINE(_XOPEN_SOURCE_EXTENDED, 1, Define to activate Unix95-and-earlier features)
+ # except for Solaris 10, where it must not be defined,
+ # as it implies XPG4.2
+ case $ac_sys_system/$ac_sys_release in
+ SunOS/5.10)
+ ;;
+ *)
+ AC_DEFINE(_XOPEN_SOURCE_EXTENDED, 1,
+ Define to activate Unix95-and-earlier features)
+ ;;
+ esac
AC_DEFINE(_POSIX_C_SOURCE, 200112L, Define to activate features from IEEE Stds 1003.1-2001)