summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorNeal Norwitz <nnorwitz@gmail.com>2003-04-11 15:35:53 (GMT)
committerNeal Norwitz <nnorwitz@gmail.com>2003-04-11 15:35:53 (GMT)
commit7f2588c073e80ab9932f69d1c5766aa73f4ae7d0 (patch)
treeefea598e6e27c461a2a37cc2eb6968b82f970d7c /configure.in
parentbae5c965e8d42c791ec42959f7b025f29f38926e (diff)
downloadcpython-7f2588c073e80ab9932f69d1c5766aa73f4ae7d0.zip
cpython-7f2588c073e80ab9932f69d1c5766aa73f4ae7d0.tar.gz
cpython-7f2588c073e80ab9932f69d1c5766aa73f4ae7d0.tar.bz2
SF patch #706707, time.tzset standards compliance update by Stuart Bishop
Update configure and test to use proper timezone specifications
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 34c7238..0638b15 100644
--- a/configure.in
+++ b/configure.in
@@ -2552,10 +2552,10 @@ int main()
int eastern_hour;
time_t now;
now = time((time_t*)NULL);
- putenv("TZ=GMT");
+ putenv("TZ=UTC+0");
tzset();
gmt_hour = localtime(&now)->tm_hour;
- putenv("TZ=US/Eastern");
+ putenv("TZ=EST+5EDT,M4.1.0,M10.5.0");
tzset();
eastern_hour = localtime(&now)->tm_hour;
if (eastern_hour == gmt_hour)