summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2003-06-14 07:48:07 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2003-06-14 07:48:07 (GMT)
commit8316feb155c3db0114259eab86a7a19cf345cd2e (patch)
tree047590c9a9abb1cfb4c6f48f284503c4b7ea0f9a /configure.in
parentba8f5ff76c8e0aa7767a9a7c59f25a2db95f5d57 (diff)
downloadcpython-8316feb155c3db0114259eab86a7a19cf345cd2e.zip
cpython-8316feb155c3db0114259eab86a7a19cf345cd2e.tar.gz
cpython-8316feb155c3db0114259eab86a7a19cf345cd2e.tar.bz2
Explicitly undefine PACKAGE_ variables. Fixes #746012.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index a5de444..963c664 100644
--- a/configure.in
+++ b/configure.in
@@ -9,8 +9,8 @@ AC_INIT(python, PYTHON_VERSION)
AC_CONFIG_SRCDIR([Include/object.h])
AC_CONFIG_HEADER(pyconfig.h)
-# This is for stuff that absolutely must end up in pyconfig.h.
-# Please use pyport.h instead, if possible.
+dnl This is for stuff that absolutely must end up in pyconfig.h.
+dnl Please use pyport.h instead, if possible.
AH_TOP([
#ifndef Py_PYCONFIG_H
#define Py_PYCONFIG_H
@@ -24,6 +24,12 @@ AH_BOTTOM([
#endif /*Py_PYCONFIG_H*/
])
+# We don't use PACKAGE_ variables, and they cause conflicts
+# with other autoconf-based packages that include Python.h
+grep -v 'define PACKAGE_' <confdefs.h >confdefs.h.new
+rm confdefs.h
+mv confdefs.h.new confdefs.h
+
AC_SUBST(VERSION)
VERSION=PYTHON_VERSION