summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2002-12-30 22:23:40 (GMT)
committerJack Jansen <jack.jansen@cwi.nl>2002-12-30 22:23:40 (GMT)
commit83f898c86c5ce68eaddd8f729a67ae2d7d0666ec (patch)
tree26e50187e882dc0a162131ec1b0e44408f9f3e84 /configure.in
parent5efc50d8afd31dc4cb0ef1b58899943eb0e4cb67 (diff)
downloadcpython-83f898c86c5ce68eaddd8f729a67ae2d7d0666ec.zip
cpython-83f898c86c5ce68eaddd8f729a67ae2d7d0666ec.tar.gz
cpython-83f898c86c5ce68eaddd8f729a67ae2d7d0666ec.tar.bz2
Adapted for the move of Mac/Lib to Lib/plat-mac. Makefile.pre.in now
knows about plat-mac subdirectories, and configure adds a variable EXTRAPLATDIR. These together take care of copying Lib/plat-mac to the destination on darwin. Adding plat-mac is still done with a .pth file which is only created when you do a framework build. I'm not 100% happy with this, but fixing it really needs a functional pythonw in non-framework builds, and I don't think I can do that before 2.3a1 (but I'll try:-).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 4869dd1..e461658 100644
--- a/configure.in
+++ b/configure.in
@@ -104,7 +104,7 @@ then
'') MACHDEP="unknown";;
esac
fi
-
+
# Some systems cannot stand _XOPEN_SOURCE being defined at all; they
# disable features if it is defined, without any means to access these
# features as extensions. For these systems, we skip the definition of
@@ -155,6 +155,18 @@ then
fi
AC_MSG_RESULT($MACHDEP)
+# And add extra plat-mac for darwin
+AC_SUBST(EXTRAPLATDIR)
+AC_MSG_CHECKING(EXTRAPLATDIR)
+if test -z "$EXTRAPLATDIR"
+then
+ case $MACHDEP in
+ darwin) EXTRAPLATDIR="\$(PLATMACDIRS)";;
+ *) EXTRAPLATDIR="";;
+ esac
+fi
+AC_MSG_RESULT($EXTRAPLATDIR)
+
# checks for alternative programs
AC_MSG_CHECKING(for --without-gcc)
AC_ARG_WITH(gcc,