summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorNeal Norwitz <nnorwitz@gmail.com>2003-03-21 01:42:58 (GMT)
committerNeal Norwitz <nnorwitz@gmail.com>2003-03-21 01:42:58 (GMT)
commit865400fd07adfae27c83dbf71e56c202d0420519 (patch)
treeac93374d53cb2583e5dc6b42619d73d778fffd48 /configure.in
parent7d8145268ee282f14d6adce9305dc3c1c7ffec14 (diff)
downloadcpython-865400fd07adfae27c83dbf71e56c202d0420519.zip
cpython-865400fd07adfae27c83dbf71e56c202d0420519.tar.gz
cpython-865400fd07adfae27c83dbf71e56c202d0420519.tar.bz2
/dev/ptmx doesn't exist on AIX, they had to be different and use /dev/ptc.
Otherwise, the 2 devices seem to work the same for allocating a pseudo-tty.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 229caef..bc57591 100644
--- a/configure.in
+++ b/configure.in
@@ -2602,6 +2602,17 @@ else
AC_MSG_RESULT(no)
fi
+AC_MSG_CHECKING(for /dev/ptc)
+
+if test -e /dev/ptc
+then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_DEV_PTC, 1,
+ [Define if we have /dev/ptc.])
+else
+ AC_MSG_RESULT(no)
+fi
+
AC_CHECK_TYPE(socklen_t,,
AC_DEFINE(socklen_t,int,
Define to `int' if <sys/socket.h> does not define.),[