summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>1997-05-09 02:42:00 (GMT)
committerGuido van Rossum <guido@python.org>1997-05-09 02:42:00 (GMT)
commit9327422093a34b08c2d8e3397664c98c046354f7 (patch)
tree0b2f0278e00d78859ff74dd5e59df6abc2f2b78a /configure.in
parent7a24c374444e4ad8994cf5147964dbfcff441955 (diff)
downloadcpython-9327422093a34b08c2d8e3397664c98c046354f7.zip
cpython-9327422093a34b08c2d8e3397664c98c046354f7.tar.gz
cpython-9327422093a34b08c2d8e3397664c98c046354f7.tar.bz2
Added --with-fpectl. Change checks for -lm, -lc.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 25 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 4e95cd3..7d000bf 100644
--- a/configure.in
+++ b/configure.in
@@ -500,25 +500,46 @@ AC_MSG_RESULT($va_list_is_array)
# Linux requires this for correct f.p. operations
AC_CHECK_LIB(ieee, __fpu_control)
+# Check for --with-fpectl
+AC_SUBST(WANT_SIGFPE_HANDLER)
+AC_MSG_CHECKING(for --with-fpectl)
+AC_ARG_WITH(fpectl, [--with-fpectl enable SIGFPE catching], [
+if test "$withval" != no
+then AC_DEFINE(WANT_SIGFPE_HANDLER) AC_MSG_RESULT(yes)
+else AC_MSG_RESULT(no)
+fi])
+
# check for --with-libm=...
AC_SUBST(LIBM)
case $ac_sys_system in
next) ;;
*) LIBM=-lm
esac
+AC_MSG_CHECKING(for --with-libm=STRING)
AC_ARG_WITH(libm, [--with-libm=STRING math library], [
-if test "$withval" != yes
+if test "$withval" = no
+then LIBM=
+ AC_MSG_RESULT(force LIBM empty)
+elif test "$withval" != yes
then LIBM=$withval
+ AC_MSG_RESULT(set LIBM=\"$withval\")
else AC_ERROR(proper usage is --with-libm=STRING)
-fi])
+fi],
+[AC_MSG_RESULT(default LIBM=\"$LIBM\")])
# check for --with-libc=...
AC_SUBST(LIBC)
+AC_MSG_CHECKING(for --with-libc=STRING)
AC_ARG_WITH(libc, [--with-libc=STRING C library], [
-if test "$withval" != yes
+if test "$withval" = no
+then LIBC=
+ AC_MSG_RESULT(force LIBC empty)
+elif test "$withval" != yes
then LIBC=$withval
+ AC_MSG_RESULT(set LIBC=\"$withval\")
else AC_ERROR(proper usage is --with-libc=STRING)
-fi])
+fi],
+[AC_MSG_RESULT(default LIBC=\"$LIBC\")])
# check for hypot() in math library
LIBS_SAVE=$LIBS