summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2002-10-04 07:21:24 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2002-10-04 07:21:24 (GMT)
commita7a76d3d9eb77b4dd3129d34ba8df636ce2e6014 (patch)
tree0cc2558cbe36eed85ac9a84cd304a856c9977f8c /configure.in
parent3d61a06aa288f2fc64f33c6b09c0778ac4083861 (diff)
downloadcpython-a7a76d3d9eb77b4dd3129d34ba8df636ce2e6014.zip
cpython-a7a76d3d9eb77b4dd3129d34ba8df636ce2e6014.tar.gz
cpython-a7a76d3d9eb77b4dd3129d34ba8df636ce2e6014.tar.bz2
Patch #618347: Work around Solaris 2.6 pthread.h bug. Will backport to 2.2.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 27462a6..fef6e22 100644
--- a/configure.in
+++ b/configure.in
@@ -1326,6 +1326,14 @@ pthread_create (NULL, NULL, start_routine, NULL)], [
OSF1) LDLAST=-threads;;
esac
fi
+
+ if test "$posix_threads" = yes -a \
+ "$ac_sys_system" = "SunOS" -a \
+ "$ac_sys_release" = "5.6"; then
+ AC_DEFINE(HAVE_PTHREAD_DESTRUCTOR, 1,
+ [Defined for Solaris 2.6 bug in pthread header.])
+ fi
+
fi
# Check for enable-ipv6