summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>1995-06-14 18:21:23 (GMT)
committerGuido van Rossum <guido@python.org>1995-06-14 18:21:23 (GMT)
commitb65a48e2b631f9a171e6eab699974bd2074f40d7 (patch)
tree1851f550d1557d7d3fac5e53dd3c611a5cc41145 /configure.in
parent3c294caa7ac8957aea008c547beb41c714e84a56 (diff)
downloadcpython-b65a48e2b631f9a171e6eab699974bd2074f40d7.zip
cpython-b65a48e2b631f9a171e6eab699974bd2074f40d7.tar.gz
cpython-b65a48e2b631f9a171e6eab699974bd2074f40d7.tar.bz2
linux elf shlib; sys/wait.h; don't add -posix for NeXT
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 6 insertions, 14 deletions
diff --git a/configure.in b/configure.in
index 78ec997..3c55a4d 100644
--- a/configure.in
+++ b/configure.in
@@ -49,22 +49,11 @@ fi
# checks for UNIX variants that set C preprocessor variables
AC_AIX
-AC_ISC_POSIX
AC_MINIX
-was_it_defined=no
-AC_TRY_RUN([
-#ifdef _NEXT_SOURCE
-main() { exit(0); }
-#endif
-], AC_DEFINE(_POSIX_SOURCE)
-CC="$CC -posix"; was_it_defined=yes)
-AC_MSG_CHECKING(for NeXT)
-AC_MSG_RESULT($was_it_defined)
-
# checks for header files
AC_HEADER_STDC
-AC_CHECK_HEADERS(dlfcn.h fcntl.h limits.h signal.h stdarg.h stddef.h stdlib.h thread.h unistd.h utime.h sys/audioio.h sys/param.h sys/select.h sys/time.h sys/times.h sys/un.h sys/utsname.h)
+AC_CHECK_HEADERS(dlfcn.h fcntl.h limits.h signal.h stdarg.h stddef.h stdlib.h thread.h unistd.h utime.h sys/audioio.h sys/param.h sys/select.h sys/time.h sys/times.h sys/un.h sys/utsname.h sys/wait.h)
AC_HEADER_DIRENT
# checks for typedefs
@@ -125,12 +114,13 @@ then
hp*|HP*) LDSHARED="ld -b";;
OSF*) LDSHARED="ld -shared -expect_unresolved \"*\"";;
DYNIX/ptx*) LDSHARED="ld -G";;
+ Linux*) LDSHARED="gcc-elf -shared";;
*) LDSHARED="ld";;
esac
fi
AC_MSG_RESULT($LDSHARED)
# CCSHARED are the C *flags* used to create objects to go into a shared
-# library -- this is only needed for HP-UX
+# library -- this is only needed for a few systems
AC_MSG_CHECKING(CCSHARED)
if test -z "$CCSHARED"
then
@@ -139,16 +129,18 @@ then
then CCSHARED="-fpic";
else CCSHARED="+z";
fi;;
+ Linux*) CCSHARED="-fpic";;
esac
fi
AC_MSG_RESULT($CCSHARED)
# LINKFORSHARED are the flags passed to the $(CC) command that links
-# the python executable -- this is only needed for HP-UX
+# the python executable -- this is only needed for a few systems
AC_MSG_CHECKING(LINKFORSHARED)
if test -z "$LINKFORSHARED"
then
case $ac_sys_system in
hp*|HP*) LINKFORSHARED="-Wl,-E";;
+ Linux*) LINKFORSHARED="-rdynamic";;
esac
fi
AC_MSG_RESULT($LINKFORSHARED)